aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2022-04-27 12:08:25 +0200
committerWojtek Kosior <koszko@koszko.org>2022-04-27 12:08:25 +0200
commitae96024993f111bcb1e48824f5f63be63ef38b1f (patch)
treecaa5f87385a97b1e94aab12318caa6fc0bf6d8a6 /pyproject.toml
parent376425d547b12f0e09c7c9636ad891a3ede0e272 (diff)
downloadhaketilo-hydrilla-ae96024993f111bcb1e48824f5f63be63ef38b1f.tar.gz
haketilo-hydrilla-ae96024993f111bcb1e48824f5f63be63ef38b1f.zip
New upstream version 1.0upstream/1.0
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..623201c
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: CC0-1.0
+
+# Copyright (C) 2022 Wojtek Kosior <koszko@koszko.org>
+#
+# Available under the terms of Creative Commons Zero v1.0 Universal.
+
+[build-system]
+build-backend = "setuptools.build_meta"
+requires = ["setuptools>=44", "wheel", "setuptools_scm>=5.0", "babel"]
+
+[tool.setuptools_scm]
+write_to = "src/hydrilla/server/_version.py"
+
+[tool.pytest.ini_options]
+minversion = "6.0"
+addopts = "-ra -q"
+testpaths = [
+ "tests"
+]