aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2022-04-22 19:27:57 +0200
committerWojtek Kosior <koszko@koszko.org>2022-04-26 13:22:18 +0200
commitbbb9e6fbbec3f6f83b72baf9d337b93aa5f0cb21 (patch)
treeefa79b0e5509d9e919044be2c1a86735f74bf516 /debian/rules
parent376425d547b12f0e09c7c9636ad891a3ede0e272 (diff)
downloadhaketilo-hydrilla-bbb9e6fbbec3f6f83b72baf9d337b93aa5f0cb21.tar.gz
haketilo-hydrilla-bbb9e6fbbec3f6f83b72baf9d337b93aa5f0cb21.zip
add debian/ directory
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..76c1b3d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#! /usr/bin/make -f
+
+# SPDX-License-Identifier: CC0-1.0
+
+# Hydrilla's debian/rules file
+#
+# Copyright (C) 2021,2022 Wojtek Kosior
+#
+# Available under the terms of Creative Commons Zero v1.0 Universal.
+
+export DH_VERBOSE = 1
+export PYBUILD_NAME = hydrilla
+export PYBUILD_TEST_PYTEST = 1
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_install:
+ dh_auto_install
+ # Namespaces. python3-hydrilla.builder package will provide the
+ # __init__.py file.
+ for DIR in ./debian/python3-hydrilla/usr/lib/python*; do \
+ rm -f $$DIR/dist-packages/hydrilla/__init__.py; \
+ done