aboutsummaryrefslogtreecommitdiff
#! /usr/bin/make -f

# SPDX-License-Identifier: CC0-1.0

# Hydrilla's debian/rules file
#
# Copyright (C) 2021,2022 Wojtek Kosior
#
# Available under the terms of Creative Commons Zero v1.0 Universal.

export DH_VERBOSE = 1
export PYBUILD_NAME = hydrilla
export PYBUILD_TEST_PYTEST = 1

%:
	dh $@ --with python3 --buildsystem=pybuild

override_dh_auto_install:
	dh_auto_install
	# Namespaces. python3-hydrilla.builder package will provide the
	# __init__.py file.
	for DIR in ./debian/python3-hydrilla/usr/lib/python*; do \
		rm -f $$DIR/dist-packages/hydrilla/__init__.py; \
	done