;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages yasm) #:use-module (gnu packages) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages python) #:use-module (gnu packages xml)) (define-public yasm (package (name "yasm") (version "1.2.0") (source (origin (method url-fetch) (uri (string-append "http://www.tortall.net/projects/yasm/releases/yasm-" version ".tar.gz")) (sha256 (base32 "0cfg7ji3ia2in628w42wrfvw2ixmmm4rghwmv2k202mraysgm3vn")))) (build-system gnu-build-system) (inputs `(("python" ,python-wrapper) ("xmlto" ,xmlto))) (home-page "http://yasm.tortall.net/") (synopsis "Rewrite of the NASM assembler") (description "Yasm is a complete rewrite of the NASM assembler. Yasm currently supports the x86 and AMD64 instruction sets, accepts NASM and GAS assembler syntaxes, outputs binary, ELF32, ELF64, 32 and 64-bit Mach-O, RDOFF2, COFF, Win32, and Win64 object formats, and generates source debugging information in STABS, DWARF 2, and CodeView 8 formats.") (license (license:bsd-style "file://COPYING" "See COPYING in the distribution.")))) 64e23853b069d861ed1deeeebecda1705e4'>root/gnu/packages/boost.scm
AgeCommit message (Expand)Author
2022-08-11gnu: mdds: Update to 2.0.3.Marius Bakke
2022-05-31gnu: Remove boost-with-python2.Maxim Cournoyer
2021-12-17gnu: boost-sync: Update to 1.55-1-e690de2d.Aleksandr Vityazev
2021-12-15gnu: boost-signals2: Update hash to matched moved tag.Aleksandr Vityazev
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-11gnu: boost: Update to 1.77.0.Maxim Cournoyer
2021-11-08gnu: packages: Remove last year's deprecations.Tobias Geerinckx-Rice
2021-07-24gnu: Use 'search-input-file' when looking for executables.Ludovic Courtès
2021-07-24gnu: Use 'search-input-directory' when looking for C/C++ library headers.Ludovic Courtès
2021-06-19Merge branch 'master' into core-updatesMarius Bakke
2021-06-14gnu: Add boost-for-irods.Ricardo Wurmus
2021-05-22gnu: boost: Update to 1.76.0.Marius Bakke
2021-05-15Merge branch 'master' into core-updatesLudovic Courtès
2021-05-11gnu: boost: Migrate uri from bintray.Greg Hogan
2021-04-16Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner
2021-04-09gnu: Add boost-mpi.Franck Pérignon
2021-03-17gnu: Use PACKAGE/INHERIT in more places.Mark H Weaver