;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; Copyright © 2015 Andreas Enge ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages xnee) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gtk) #:use-module (gnu packages pkg-config) #:use-module (gnu packages xorg)) (define-public xnee (package (name "xnee") (version "3.19") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/xnee/xnee-" version ".tar.gz")) (sha256 (base32 "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j")))) (build-system gnu-build-system) (inputs `(("gtk+", gtk+-2) ("inputproto" ,inputproto) ("libx11" ,libx11) ("libxext" ,libxext) ("libxi" ,libxi) ("libxtst" ,libxtst) ("recordproto" ,recordproto) ("xextproto" ,xextproto) ("xproto" ,xproto))) (native-inputs `(("pkg-config" ,pkg-config))) (home-page "http://www.gnu.org/software/xnee/") (synopsis "Record, replay and distribute user actions under X11") (description "GNU Xnee is a program that can record, replay and distribute user actions in X11. It can be used to automate user interactions for testing or demonstration purposes.") (license gpl3+))) a>/gnu/packages/plotutils.scm
AgeCommit message (Expand)Author
2017-01-29gnu: asymptote: Update to 2.39...Nicolas Goaziou
2016-09-02gnu: Use ghostscript over ghostscript-gs....Efraim Flashner
2016-07-28gnu: asymptote: Add native input gs....Andreas Enge
2016-07-25gnu: Use 'ghostscript-gs' in packages that need the 'gs' command....Ludovic Courtès
2016-06-13gnu: asymptote: Update to 2.38...Nicolas Goaziou
2016-05-26gnu: Rename texlive module to tex....Roel Janssen
2016-05-24gnu: Use 'emacs-minimal' instead of 'emacs-no-x'....Alex Kost
2016-05-16gnu: asymptote: Install Emacs data....Nicolas Goaziou
2016-05-01gnu: asymptote: Update to 2.37....Nicolas Goaziou
2016-04-14gnu: packages: Use 'search-patches' everywhere....Alex Kost
2016-01-13Merge branch 'master' into core-updatesLudovic Courtès
2016-01-02gnu: Add Asymptote....Eric Bavier
2015-03-31utils: 'modify-phases' no longer introduces quotes....Ludovic Courtès
2015-03-09gnu: Add Ploticus....Ludovic Courtès
2015-01-19gnu: Move guile-charting to (gnu packages plotutils)....Ludovic Courtès
2015-01-15gnu: plotutils: Do not propagate libXaw....Ludovic Courtès