;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; Copyright © 2015 Andreas Enge ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages xnee) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gtk) #:use-module (gnu packages pkg-config) #:use-module (gnu packages xorg)) (define-public xnee (package (name "xnee") (version "3.19") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/xnee/xnee-" version ".tar.gz")) (sha256 (base32 "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j")))) (build-system gnu-build-system) (inputs `(("gtk+" ,gtk+-2) ("libx11" ,libx11) ("libxext" ,libxext) ("libxi" ,libxi) ("libxtst" ,libxtst) ("xorgproto" ,xorgproto))) (native-inputs `(("pkg-config" ,pkg-config))) (home-page "https://www.gnu.org/software/xnee/") (synopsis "Record, replay and distribute user actions under X11") (description "GNU Xnee is a program that can record, replay and distribute user actions in X11. It can be used to automate user interactions for testing or demonstration purposes.") (license gpl3+))) 10a'>root/.dir-locals.el
AgeCommit message (Expand)Author
2020-05-16gexp: Add 'let-system'....Ludovic Courtès
2020-03-22store: Add 'with-build-handler'....Ludovic Courtès
2020-03-12gexp: Add 'with-parameters'....Ludovic Courtès
2019-11-29ui: Factorize 'with-profile-lock'....Ludovic Courtès
2019-11-19pull: Acquire a lock for the target profile....Ludovic Courtès
2019-09-23git: Add 'commit-difference'....Ludovic Courtès
2019-06-05syscalls: Add 'with-file-lock' macro....Ludovic Courtès
2019-05-27publish: Add support for lzip....Ludovic Courtès
2019-03-07database: Make 'register-items' transactional....Caleb Ristvedt
2019-01-11status: Add 'with-status-verbosity'....Ludovic Courtès
2018-10-19tests: Run 'guix pack' tests using the external store....Ludovic Courtès
2018-09-27Add (guix status) and use it for pretty colored output....Ludovic Courtès
2018-06-01Add (gnu store database)....Caleb Ristvedt
2018-06-01gexp: Add 'with-extensions'....Ludovic Courtès
2018-01-08services: guix: Add 'log-compression' option....Ludovic Courtès
2017-12-01weather: Use (guix progress) for progress report....Ludovic Courtès