;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; Copyright © 2015 Andreas Enge ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages xnee) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gtk) #:use-module (gnu packages pkg-config) #:use-module (gnu packages xorg)) (define-public xnee (package (name "xnee") (version "3.19") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/xnee/xnee-" version ".tar.gz")) (sha256 (base32 "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j")))) (build-system gnu-build-system) (inputs `(("gtk+" ,gtk+-2) ("libx11" ,libx11) ("libxext" ,libxext) ("libxi" ,libxi) ("libxtst" ,libxtst) ("xorgproto" ,xorgproto))) (native-inputs `(("pkg-config" ,pkg-config))) (home-page "https://www.gnu.org/software/xnee/") (synopsis "Record, replay and distribute user actions under X11") (description "GNU Xnee is a program that can record, replay and distribute user actions in X11. It can be used to automate user interactions for testing or demonstration purposes.") (license gpl3+))) ref='/guix/log/?id=debb5ad5e0a0785d8ffb6f5ab326685520223760'>root/gnu/packages/emacs.scm
AgeCommit message (Expand)Author
2020-12-01gnu: emacs-next-pgtk: Update to savannah feature/pgtk branch....Ryan Prior
2020-11-26gnu: Add emacs-next-pgtk....Andrew Tropin
2020-11-11gnu: emacs.scm: Remove unused module import....Marius Bakke
2020-11-03Revert "gnu: emacs: Make strip-double-wrap more robust."...Nicolas Goaziou
2020-11-03gnu: emacs: Make strip-double-wrap more robust....Morgan Smith
2020-10-01gnu: emacs-next: Fix load path and version....Morgan Smith
2020-09-02gnu: Add emacs-next....Morgan Smith
2020-08-31gnu: emacs: Strip double wrap....Leo Prikler
2020-08-29Revert "gnu: emacs: Strip double wrap."...Mathieu Othacehe
2020-08-29gnu: emacs: Strip double wrap....Leo Prikler
2020-08-28gnu: emacs: Update to 27.1....Mark H Weaver
2020-08-03gnu: emacs: Ignore empty XIM styles....Leo Prikler