;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; Copyright © 2015 Andreas Enge ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages xnee) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gtk) #:use-module (gnu packages pkg-config) #:use-module (gnu packages xorg)) (define-public xnee (package (name "xnee") (version "3.19") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/xnee/xnee-" version ".tar.gz")) (sha256 (base32 "04n2lac0vgpv8zsn7nmb50hf3qb56pmj90dmwnivg09gyrf1x92j")))) (build-system gnu-build-system) (inputs `(("gtk+" ,gtk+-2) ("libx11" ,libx11) ("libxext" ,libxext) ("libxi" ,libxi) ("libxtst" ,libxtst) ("xorgproto" ,xorgproto))) (native-inputs `(("pkg-config" ,pkg-config))) (home-page "https://www.gnu.org/software/xnee/") (synopsis "Record, replay and distribute user actions under X11") (description "GNU Xnee is a program that can record, replay and distribute user actions in X11. It can be used to automate user interactions for testing or demonstration purposes.") (license gpl3+))) configure.ac
AgeCommit message (Expand)Author
2020-06-16etc: Add committer script....Ricardo Wurmus
2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès
2020-05-14etc: indent-code.el: Use the --quick option....Maxim Cournoyer
2020-04-23build: Don't build man pages when cross-compiling....Ludovic Courtès
2020-03-11build: Require Guile 2.2.3 or later....Ludovic Courtès
2020-01-17build: Allow builds with Guile 3.0....Ludovic Courtès
2019-11-09build: Warn about etc/indent-code.el when Emacs is absent....zimoun
2019-07-25maint: Switch to Guile-JSON 3.x....Ludovic Courtès
2019-05-06Add (guix lzlib)....Pierre Neidhardt
2019-04-17build: No longer substitute 'LIBGCRYPT'....Ludovic Courtès
2019-01-17configure: Disable installer build by default....Mathieu Othacehe
2019-01-17gnu: Add graphical installer support....Mathieu Othacehe
2019-01-09build: Require Guile 2.2....Ludovic Courtès
2018-12-02Make Guile-JSON a required dependency....Eric Bavier