;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Marek Benc ;;; Copyright © 2017 Leo Famulari ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages wv) #:use-module (gnu packages) #:use-module (gnu packages compression) #:use-module (gnu packages glib) #:use-module (gnu packages gnome) #:use-module (gnu packages image) #:use-module (gnu packages pkg-config) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:)) (define-public wv (package (name "wv") (version "1.2.9") (source (origin (method url-fetch) (uri (string-append "https://abiword.org/downloads/wv/" version "/wv-" version ".tar.gz")) (sha256 (base32 "17f16lkdv1c3amaz2hagiicih59ynpp4786k1m2qa1sw68xhswsc")))) (build-system gnu-build-system) (inputs (list glib libgsf libjpeg-turbo libpng zlib)) (native-inputs (list `(,glib "bin") pkg-config)) (synopsis "Microsoft Word conversion library and utilities") (description "wv converts files written by Word 2000, 97, 95, and 6 (known internally as Word 9, 8, 7, and 6) to HTML or LaTeX. Word 2 documents can still be converted to plain text but will lack formatting. Other programs can use wv as a library to convert Word documents to other formats. AbiWord uses it as its Word importer, and KWord uses concepts and code from wv in theirs.") (home-page "https://wvware.sourceforge.net/") (license license:gpl2+))) uix/log/tests/services/linux.scm?id=5680ca81686110f3c66de40f512e4f9f45c8a25d'>linux.scm
=8338d414b361e4fb961221642c1064e9dc89ba65'>installer: Limit listbox height....
AgeCommit message (2023-07-192020-08-02services: Add zram-device-service....Efraim Flashner
Mathieu Othacehe
2020-03-05installer: Bypass connectivity check when /tmp/installer-assume-online exists....Ludovic Courtès
2019-06-08installer: Fix typo....Tobias Geerinckx-Rice
2019-05-06installer: Skip network selection dialogs when there is no choice....Ludovic Courtès
2019-05-06installer: Shrink simple listboxes to their minimum height....Ludovic Courtès
2019-04-25installer: Add missing 'G_' for networking message....Ludovic Courtès
2019-04-07installer: Fix wording for "Internet access."...Ludovic Courtès
2019-03-13installer: network: Adjust wording....Ludovic Courtès
2019-01-17installer: Make sure every sentence is dot terminated....Mathieu Othacehe
2019-01-17installer: network: Do not show an empty technology list....Mathieu Othacehe
2019-01-17installer: Turn "Cancel" buttons into "Exit" buttons....Mathieu Othacehe
2019-01-17installer: Fix compute calls....Mathieu Othacehe
2019-01-17installer: Remove "selection" from all titles....Mathieu Othacehe
2019-01-17gnu: Add graphical installer support....Mathieu Othacehe