;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Marek Benc ;;; Copyright © 2017 Leo Famulari ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages wv) #:use-module (gnu packages) #:use-module (gnu packages compression) #:use-module (gnu packages glib) #:use-module (gnu packages gnome) #:use-module (gnu packages image) #:use-module (gnu packages pkg-config) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:)) (define-public wv (package (name "wv") (version "1.2.9") (source (origin (method url-fetch) (uri (string-append "https://abiword.org/downloads/wv/" version "/wv-" version ".tar.gz")) (sha256 (base32 "17f16lkdv1c3amaz2hagiicih59ynpp4786k1m2qa1sw68xhswsc")))) (build-system gnu-build-system) (inputs `(("glib" ,glib) ("libgsf" ,libgsf) ("libjpeg" ,libjpeg-turbo) ("libpng" ,libpng) ("zlib" ,zlib))) (native-inputs `(("glib" ,glib "bin") ("pkg-config" ,pkg-config))) (synopsis "Microsoft Word conversion library and utilities") (description "wv converts files written by Word 2000, 97, 95, and 6 (known internally as Word 9, 8, 7, and 6) to HTML or LaTeX. Word 2 documents can still be converted to plain text but will lack formatting. Other programs can use wv as a library to convert Word documents to other formats. AbiWord uses it as its Word importer, and KWord uses concepts and code from wv in theirs.") (home-page "http://wvware.sourceforge.net/") (license license:gpl2+))) ss='content'>
AgeCommit message (Expand)Author
2017-10-20gnu: Fix the hashes of mutated GitHub archives....Maxim Cournoyer
2017-09-20gnu: Use 'modify-phases' syntax....Kei Kebreau
2017-09-18gnu: blender: Update to 2.79....Efraim Flashner
2017-09-17gnu: Add python-pastel....Ben Woodcroft
2017-08-17gnu: Add ogre....Manolis Ragkousis
2017-08-03gnu: openscenegraph: Add 'Release' configure flag....Manolis Ragkousis
2017-06-20gnu: Move contents of zip module into compression module....Arun Isaac
2017-06-05gnu: openscenegraph: Tweak description....Ludovic Courtès
2017-06-04gnu: Add openscenegraph....Manolis Ragkousis
2017-05-24gnu: brdf-explorer: Update to 1.0.0-1.5b2cd46f3....Ricardo Wurmus
2017-04-05Revert "gnu: openexr: Add IlmBase include sub-directory to 'OpenEXR.pc'."...Ludovic Courtès
2017-04-05gnu: openexr: Add IlmBase include sub-directory to 'OpenEXR.pc'....Ludovic Courtès
2017-04-02gnu: brdf-explorer: Use HTTPS source URL....Leo Famulari
2016-10-27gnu: blender: Update to 2.78a....Leo Famulari
2016-10-15gnu: assimp: Update to 3.3.1....Efraim Flashner
2016-09-16gnu: Add assimp....Ricardo Wurmus