;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Marek Benc ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages wv) #:use-module (gnu packages) #:use-module (gnu packages compression) #:use-module (gnu packages glib) #:use-module (gnu packages gnome) #:use-module (gnu packages image) #:use-module (gnu packages pkg-config) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:)) (define-public wv (package (name "wv") (version "1.2.4") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/wvware/wv/" version "/wv-" version ".tar.gz")) (sha256 (base32 "1mn2ax6qjy3pvixlnvbkn6ymy6y4l2wxrr4brjaczm121s8hjcb7")))) (build-system gnu-build-system) (arguments `(#:configure-flags '("--with-libwmf"))) (inputs `(("glib" ,glib) ("libgsf" ,libgsf) ("libjpeg" ,libjpeg) ("libpng" ,libpng) ("libwmf" ,libwmf) ("zlib" ,zlib))) (native-inputs `(("glib" ,glib "bin") ("pkg-config" ,pkg-config))) (synopsis "Microsoft Word conversion library and utilities") (description "wv converts Word 2,6,7,8,9 files to HTML and LaTeX. The Word 2 conversion is still incomplete (no formatting), but it will do a passable job extracting the text, which is what you probably want anyway. libwv can be used as a library by third party programs, AbiWord uses it as its word importer, and KWord may use it in the future.") (home-page "http://wvware.sourceforge.net/") (license license:gpl2+))) nt'>
AgeCommit message (Expand)Author
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-05-22gnu: SWIG: Update to 4.0.2.Marius Bakke
2020-03-18gnu: swig: Use guile-3.0 instead of guile-2.2.Arun Isaac
2019-12-12gnu: swig: Build with guile-2.2.Efraim Flashner
2019-12-05gnu: swig: Update to 4.0.1.Marius Bakke
2019-12-01gnu: swig.scm: Sort module inputs alphabetically.Efraim Flashner
2019-12-01gnu: swig: Clean up inputs.Efraim Flashner
2019-11-15gnu: swig: Fix cross-compilation.Mathieu Othacehe
2019-02-09gnu: swig: Fix FTBFS with GCC >= 6.Marius Bakke
2018-10-18gnu: swig: Fix build on i686.Marius Bakke
2018-05-30Revert "gnu: swig: Patch for Octave 4.4."Mark H Weaver
2018-05-29gnu: swig: Patch for Octave 4.4.Kei Kebreau
2017-06-14gnu: swig: Fix build with Perl 5.26.0.Leo Famulari
2017-06-14gnu: swig: Update to 3.0.12.Leo Famulari
2016-11-21gnu: swig: Update to 3.0.10.Leo Famulari