;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2014 Mark H Weaver ;;; Copyright © 2015, 2016 Efraim Flashner ;;; Copyright © 2016 Kei Kebreau ;;; Copyright © 2017 Eric Bavier ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages web-browsers) #:use-module ((gui
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 22:08:20 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:06 +0000
commit88fea61aaed0498ab81928933a3b4293a7656549 (patch)
tree3eb3495ff9ec8f219f69eb9facb3cce25ce0692b /po/doc/guix-manual.de.po
parent965f6d74acb591c8ab1efe23a737a52011ba885a (diff)
downloadguix-88fea61aaed0498ab81928933a3b4293a7656549.tar.gz
guix-88fea61aaed0498ab81928933a3b4293a7656549.zip
gnu: go-github.com-smartystreets-gunit: Move to (gnu packages golang-check).
* gnu/packages/check.scm (go-github.com-smartystreets-gunit): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: I7204e118f99064027f0e10838d2b44fee212d21d
Diffstat (limited to 'po/doc/guix-manual.de.po')
0 files changed, 0 insertions, 0 deletions
"--enable-htmlized-cfg" "--enable-gzip-help" "--enable-nls" "--enable-ipv6")) #:tests? #f ; no check target #:phases (modify-phases %standard-phases (replace 'install (lambda* (#:key (make-flags '()) #:allow-other-keys) (zero? (apply system* "make" "install-full" make-flags))))))) (synopsis "Text Web Browser") (description "Lynx is a fully-featured World Wide Web (WWW) client for users running cursor-addressable, character-cell display devices. It will display Hypertext Markup Language (HTML) documents containing links to files on the local system, as well as files on remote systems running http, gopher, ftp, wais, nntp, finger, or cso/ph/qi servers. Lynx can be used to access information on the WWW, or to build information systems intended primarily for local access.") (home-page "http://lynx.isc.org/") (license license:gpl2))) (define-public qutebrowser (package (name "qutebrowser") (version "0.11.0") (source (origin (method url-fetch) (uri (string-append "https://github.com/The-Compiler/" "qutebrowser/releases/download/v" version "/" "qutebrowser-" version ".tar.gz")) (sha256 (base32 "13ihx66jm1dd6vx8px7pm0kbzf2sf9x43hhivc1rp17kahnxxdyv")))) (build-system python-build-system) (native-inputs `(("asciidoc" ,asciidoc))) (inputs `(("python-colorama" ,python-colorama) ("python-cssutils" ,python-cssutils) ("python-jinja2" ,python-jinja2) ("python-markupsafe" ,python-markupsafe) ("python-pygments" ,python-pygments) ("python-pypeg2" ,python-pypeg2) ("python-pyyaml" ,python-pyyaml) ("python-pyqt" ,python-pyqt) ("qtwebkit" ,qtwebkit))) (arguments `(#:tests? #f ;no tests #:phases (modify-phases %standard-phases (add-after 'install 'install-more (lambda* (#:key outputs #:allow-other-keys) (let* ((out (assoc-ref outputs "out")) (app (string-append out "/share/applications")) (hicolor (string-append out "/share/icons/hicolor"))) (system* "a2x" "-f" "manpage" "doc/qutebrowser.1.asciidoc") (install-file "doc/qutebrowser.1" (string-append out "/share/man/man1")) (for-each (lambda (i) (let ((src (format #f "icons/qutebrowser-~dx~d.png" i i)) (dest (format #f "~a/~dx~d/apps/qutebrowser.png" hicolor i i))) (mkdir-p (dirname dest)) (copy-file src dest))) '(16 24 32 48 64 128 256 512)) (install-file "icons/qutebrowser.svg" (string-append hicolor "/scalable/apps")) (substitute* "qutebrowser.desktop" (("Exec=qutebrowser") (string-append "Exec=" out "/bin/qutebrowser"))) (install-file "qutebrowser.desktop" app) #t)))))) (home-page "https://qutebrowser.org/") (synopsis "Minimal, keyboard-focused, vim-like web browser") (description "qutebrowser is a keyboard-focused browser with a minimal GUI. It is based on PyQt5 and QtWebKit.") (license license:gpl3+)))