;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2022 Nicolas Goaziou ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages weather) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix build-system go) #:use-module (guix git-download) #:use-module (guix packages) #:use-module (gnu packages) #:use-module (gnu packages golang)) (define-public wego (package (name "wego") (version "2.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/schachmat/wego") (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "0bji9fywa0kg29zj1vrwq7l5f18hh0lcz6rl6sppi5id0qbjpiwl")))) (build-system go-build-system) (arguments '(#:import-path "github.com/schachmat/wego")) (propagated-inputs (list go-golang-org-x-sys go-github-com-rivo-uniseg go-github-com-mattn-go-isatty go-github-com-schachmat-ingo go-github-com-mattn-go-runewidth go-github-com-mattn-go-colorable)) (home-page "https://github.com/schachmat/wego") (synopsis "Weather client for the terminal") (description "Wego is a weather client for the terminal. It shows forecast for one or seven days. Displayed information includes temperature range---felt and measured---, wind speed and direction, viewing distance, precipitation amount and probability.") (license license:isc))) uix/log/gnu?id=f9c04580bf5462bb088f47ad8fc6c3136649cbd6'>gnu/packages/astronomy.scm
700fb454edad46e84cc46edb3654e42b5172'>gnu: id3lib: Apply patch for UTF16 writing bug....
AgeCommit message (Expand)Author
2020-05-21gnu: gnuastro: Don't build static libraries....Efraim Flashner
2020-05-21gnu: gnuastro: Update to 0.12....Efraim Flashner
2020-04-30Merge branch 'master' into core-updates...Marius Bakke
2020-04-28gnu: stellarium: Update to 0.20.1....Björn Höfling
2020-04-08Merge branch 'master' into core-updates...Marius Bakke
2020-04-05gnu: astronomy: Sort list of imported package modules....Guillaume Le Vaillant
2020-04-05gnu: Add gpredict....Guillaume Le Vaillant
2020-04-04gnu: Add xplanet....R Veera Kumar
Pierre Langlois