;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Nikita Karetnikov ;;; Copyright © 2017 Eric Bavier ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages wdiff) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages texinfo) #:use-module (gnu packages screen) #:use-module (gnu packages base)) (define-public wdiff (package (name "wdiff") (version "1.2.2") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/wdiff/wdiff-" version ".tar.gz")) (sha256 (base32 "0sxgg0ms5lhi4aqqvz1rj4s77yi9wymfm3l3gbjfd1qchy66kzrl")))) (build-system gnu-build-system) (arguments `(#:phases (modify-phases %standard-phases (add-before 'check 'fix-sh (lambda _ (substitute* "tests/testsuite" (("#! /bin/sh") (string-append "#!" (which "sh"))))))))) (native-inputs (list which ;; For some reason wdiff.info gets rebuilt. texinfo)) (home-page "https://www.gnu.org/software/wdiff/") (synopsis "Word difference finder") (description "GNU Wdiff is a front-end to the diff program from Diffutils that allows you to compare files on a word-by-word basis, where a word is anything between whitespace.") (license gpl3+))) 84a8c3f3d4825ed800a8e'>snippets
AgeCommit message (Expand)Author
2023-04-19snippets: tempel: Simplify git-commit-mode detection....Nicolas Graves
2023-03-05etc: Default to variables in tempel's git-reference... et al....Liliana Marie Prikler
2023-02-19etc: Add a news entry snippet....Maxim Cournoyer
2022-12-27snippets: Remove unwanted git-commit-mode invocation....Andrew Tropin
2022-11-28snippets: yas: Add snippets for vc.el...Morgan Smith
2022-10-22snippets: Harden for review activity....Liliana Marie Prikler
2022-10-06snippets: Fix move....Liliana Marie Prikler
2022-10-06snippets: tempel: Reformat....Liliana Marie Prikler
2022-10-06snippets: tempel: Fix calls to mapconcat....Liliana Marie Prikler
2022-09-26etc: Add tempel snippet move....Nicolas Graves
2022-08-30etc: Update yasnippet build system list....Nicolas Graves
2022-08-30etc: Add tempel snippet for :phases....Nicolas Graves
2022-08-30etc: Add tempel snippets....Nicolas Graves
2022-05-12snippets: Add a 'remove' snippet....Maxim Cournoyer
2022-01-19etc: Match define-public only at line start....Liliana Marie Prikler
2021-06-26etc: snippets: Use ‘hg-file-name’ when origin uses ‘hg-fetch’...Xinglu Chen