;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Nikita Karetnikov ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages wdiff) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages texinfo) #:use-module (gnu packages screen) #:use-module (gnu packages base)) (define-public wdiff (package (name "wdiff") (version "1.2.2") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/wdiff/wdiff-" version ".tar.gz")) (sha256 (base32 "0sxgg0ms5lhi4aqqvz1rj4s77yi9wymfm3l3gbjfd1qchy66kzrl")))) (build-system gnu-build-system) (arguments `(#:phases (alist-cons-before 'check 'fix-sh (lambda _ (substitute* "tests/testsuite" (("#! /bin/sh") (string-append "#!" (which "sh"))))) %standard-phases))) (inputs `(("screen" ,screen) ("which" ,which) ;; For some reason wdiff.info gets rebuilt. ("texinfo" ,texinfo))) (home-page "https://www.gnu.org/software/wdiff/") (synopsis "Word difference finder") (description "GNU Wdiff is a front-end to the diff program from Diffutils that allows you to compare files on a word-by-word basis, where a word is anything between whitespace.") (license gpl3+))) ts/guix-pack.sh
AgeCommit message (Expand)Author
2020-09-28tests: Simplify shell exit status negation;...Eric Bavier
2020-05-14store: 'mapm/accumulate-builds' preserves '%current-target-system'....Ludovic Courtès
2020-03-31pack: Adjust test to '--dry-run' changes....Ludovic Courtès
2019-11-22pack: Allow multiple '--manifest' options....Ludovic Courtès
2019-11-21pack: Add "--derivation"....Ludovic Courtès
2019-05-22pack: Add '--root'....Ludovic Courtès
2019-05-09tests: Ensure 'unshare' works before relying on it....Ludovic Courtès
2018-11-06store-copy: Canonicalize the mtime and permissions of the store copy....Ludovic Courtès
2018-11-06pack: Import (guix store database) only when '--localstatedir' is passed....Ludovic Courtès
2018-10-19tests: Run 'guix pack' tests using the external store....Ludovic Courtès
2018-07-05tests: Skip 'guix-pack.sh'....Ludovic Courtès
2018-05-19tests: Skip 'tests/guix-pack.sh' when networking is missing....Ludovic Courtès
2018-05-10pack: Add '--relocatable'....Ludovic Courtès
2018-05-07pack: Fix handling of '-e'....Ludovic Courtès
2018-05-07pack: Honor package transformation options....Ludovic Courtès
2018-05-07pack: Adjust test to cope with GC'd profiles....Ludovic Courtès
2018-03-24tests: Add tests for "guix pack"....Chris Marusich