;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2021 Charles ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages uglifyjs) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix git-download) #:use-module (guix build-system node) #:use-module (gnu packages node-xyz)) (define-public node-uglify-js (package (name "node-uglify-js") (version "3.13.9") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/mishoo/UglifyJS") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0q1f91xwwm829cl5v727d4qkxy4yh7wri3pgl89f0m3a4y1n7hi4")))) (build-system node-build-system) (native-inputs (list node-acorn node-semver)) (home-page "https://lisperator.net/uglifyjs/") (synopsis "JavaScript parser / mangler / compressor / beautifier toolkit") (description "UglifyJS is a JavaScript compressor/minifier written in JavaScript. It also contains tools that allow one to automate working with JavaScript code: parser, code generator, compressor, mangler, scope analyzer, tree walker, and tree transformer.") (license license:bsd-2))) (define-public uglifyjs node-uglify-js) >path: root/tests/style.scm
AgeCommit message (Expand)Author
2023-05-18style: Add 'arguments' styling rule....Ludovic Courtès
2023-05-04style: Make 'safe' policy less conservative....Ludovic Courtès
2022-08-08style: Adjust test to not emit blank lines....Ludovic Courtès
2022-08-08style: Move reader and printer to (guix read-print)....Ludovic Courtès
2022-07-04style: For 'let' and similar forms, emit one binding per line....Ludovic Courtès
2022-06-22style: Keep values next to their keyword....Ludovic Courtès
2022-04-14style: Correctly read dots in pairs and improper lists....Ludovic Courtès
2022-01-10style: '-S format' canonicalizes comments....Ludovic Courtès
2022-01-10style: Add '--styling' option....Ludovic Courtès
2022-01-10style: Add support for "newline forms"....Ludovic Courtès
2022-01-10style: Allow special forms to be scoped....Ludovic Courtès
2022-01-10style: Improve pretty printer and add tests....Ludovic Courtès
2021-07-11Add 'guix style'....Ludovic Courtès