;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2021 Charles ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages uglifyjs) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix git-download) #:use-module (guix build-system node) #:use-module (gnu packages node-xyz)) (define-public node-uglify-js (package (name "node-uglify-js") (version "3.14.2") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/mishoo/UglifyJS") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1jraqpwzga4vbgq3xcn08jcfc87pm6nik7vpxvxa4rfjvz70a6k7")))) (build-system node-build-system) (native-inputs (list node-acorn node-semver)) (home-page "https://lisperator.net/uglifyjs/") (synopsis "JavaScript parser / mangler / compressor / beautifier toolkit") (description "UglifyJS is a JavaScript compressor/minifier written in JavaScript. It also contains tools that allow one to automate working with JavaScript code: parser, code generator, compressor, mangler, scope analyzer, tree walker, and tree transformer.") (license license:bsd-2))) (define-public uglifyjs node-uglify-js) ='search'/>
AgeCommit message (Expand)Author
2022-09-22gnu: Add idevicerestore....Jacob Hrbek
2022-09-22gnu: Add libirecovery....Jacob Hrbek
2022-09-22gnu: Add ideviceinstaller....Jacob Hrbek
2022-07-24gnu: libmtp: Use G-expressions....Tobias Geerinckx-Rice
2022-07-24gnu: libmtp: Update to 1.1.20....Tobias Geerinckx-Rice
2022-05-31gnu: Remove python2-hidapi....Maxim Cournoyer
2022-05-31gnu: Remove python2-pyusb....Maxim Cournoyer
2022-01-18gnu: python-libusb1: Update to 2.0.1....Marius Bakke
2021-12-13gnu: Further simplify package inputs....Ludovic Courtès
2021-12-13gnu: Simplify package inputs....Ludovic Courtès
2021-11-03Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner
2021-11-03gnu: libmtp: Update to 1.1.19....Tobias Geerinckx-Rice
2021-09-16gnu: gmtp: Fix build....Guillaume Le Vaillant
2021-08-10gnu: python-libusb1: Update to 1.9.3....Milkey Mouse