;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2021 Charles ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages uglifyjs) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix git-download) #:use-module (guix build-system node) #:use-module (gnu packages node-xyz)) (define-public node-uglify-js (package (name "node-uglify-js") (version "3.14.2") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/mishoo/UglifyJS") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1jraqpwzga4vbgq3xcn08jcfc87pm6nik7vpxvxa4rfjvz70a6k7")))) (build-system node-build-system) (native-inputs (list node-acorn node-semver)) (home-page "https://lisperator.net/uglifyjs/") (synopsis "JavaScript parser / mangler / compressor / beautifier toolkit") (description "UglifyJS is a JavaScript compressor/minifier written in JavaScript. It also contains tools that allow one to automate working with JavaScript code: parser, code generator, compressor, mangler, scope analyzer, tree walker, and tree transformer.") (license license:bsd-2))) (define-public uglifyjs node-uglify-js) size='10' name='q' value=''/>
AgeCommit message (Expand)Author
2023-03-02Merge remote-tracking branch 'savannah/master' into core-updatesChristopher Baines
2023-02-19gnu: Use HTTPS package home pages wherever possible.Tobias Geerinckx-Rice
2023-01-30Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner
2023-01-25gnu: mpc: Update to 1.3.1.Andreas Enge
2023-01-25gnu: mpfr: Update to 4.2.0.Andreas Enge
2022-11-19gnu: mpfr: Update to 4.1.1.Efraim Flashner
2022-10-03gnu: mpfi: Update to 1.5.4-1.b982534.Maxim Cournoyer
2022-10-03gnu: mpfi: Use gexps and remove input labels.Maxim Cournoyer
2021-12-18gnu: qd: Omit static library.Tobias Geerinckx-Rice
2021-12-18gnu: qd: Update to 2.3.23.Tobias Geerinckx-Rice
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner
2021-10-28gnu: Add cln.Vinicius Monego
2021-10-23gnu: Use 'search-input-file' some more.Ludovic Courtès