;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Alex Kost ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages tv) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages) #:use-module (gnu packages xorg) #:use-module (gnu packages image) #:use-module (gnu packages compression) #:use-module (gnu packages xml) #:use-module (gnu packages fontutils)) (define-public tvtime (package (name "tvtime") (version "1.0.2") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/tvtime/tvtime-" version ".tar.gz")) (sha256 (base32 "08q5gzbyz0lxb730rz6d6amkzimlc7nanv6n50j2bpw4n2xa9wmf")) (patches (list (search-patch "tvtime-videodev2.patch") (search-patch "tvtime-pngoutput.patch") (search-patch "tvtime-xmltv.patch") (search-patch "tvtime-gcc41.patch"))))) (build-system gnu-build-system) (inputs `(("libx11" ,libx11) ("libxext" ,libxext) ("libxt" ,libxt) ("libxtst" ,libxtst) ("libxinerama" ,libxinerama) ("libxv" ,libxv) ("libxxf86vm" ,libxxf86vm) ("libpng" ,libpng) ("libxml2" ,libxml2) ("freetype" ,freetype) ("zlib" ,zlib))) (home-page "http://tvtime.sourceforge.net") (synopsis "Television viewer") (description "Tvtime processes the input from your video capture card and displays it on a monitor. It focuses on a high visual quality.") (license license:gpl2+))) o.scm
AgeCommit message (Expand)Author
2022-08-14gnu: noise-suppression-for-voice: Rename from ‘rnnoise’.Tobias Geerinckx-Rice
2022-08-14gnu: noisetorch: Update to 0.12.2.Tobias Geerinckx-Rice
2022-07-24gnu: pamixer: Update to 1.6.Tobias Geerinckx-Rice
2022-07-24gnu: paprefs: Update to 1.2.Tobias Geerinckx-Rice
2022-05-31gnu: Remove pulseaudio-dlna.Maxim Cournoyer
2021-12-29gnu: Remove leftover libsndfile/fixed package.Leo Famulari
2021-12-13gnu: Further simplify package inputs.Ludovic Courtès
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-11-11gnu: pulseaudio: Add doxygen to fix build.Maxim Cournoyer
2021-11-11gnu: pulseaudio: Update to 15.0.Brice Waegeneire
2021-11-11gnu: pulseaudio: Use meson build system.Brice Waegeneire
2021-11-11gnu: pulseaudio: Update to 14.2.Brice Waegeneire
2021-11-03Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner
2021-11-03gnu: pavucontrol: Update to 5.0.Tobias Geerinckx-Rice
2021-11-03gnu: pamixer: Update to 1.5.Tobias Geerinckx-Rice