;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Cyril Roelandt ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages tmux) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages) #:use-module (gnu packages libevent) #:use-module (gnu packages ncurses)) (define-public tmux (package (name "tmux") (version "1.7") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/tmux/tmux/tmux-" version "/tmux-" version ".tar.gz")) (sha256 (base32 "0ywy1x2g905hmhkdz418ik42lcvnhnwr8fv63rcqczfg27d6nd38")))) (build-system gnu-build-system) (inputs `(("libevent" ,libevent) ("ncurses" ,ncurses))) (home-page "http://tmux.sourceforge.net/") (synopsis "A terminal multiplexer") (description "tmux is a terminal multiplexer: it enables a number of terminals (or windows), each running a separate program, to be created, accessed, and controlled from a single screen. tmux may be detached from a screen and continue running in the background, then later reattached.") (license isc))) lue=''/>
AgeCommit message (Expand)Author
2023-05-24gnu: lolcat: Update to 1.4.kiasoc5
2022-08-28gnu: Add fortunes-jkirchartz.Liliana Marie Prikler
2022-08-28gnu: Add daikichi.Liliana Marie Prikler
2022-07-17gnu: lolcat: Move to (gnu packages toys).Tobias Geerinckx-Rice
2022-06-05gnu: oneko: Edit description.Tobias Geerinckx-Rice
2022-06-05gnu: oneko: Remove trailing #t from phases.Tobias Geerinckx-Rice
2022-01-02gnu: xsnow: Simplify inputs.kiasoc5
2022-01-02gnu: xsnow: Update to 3.4.2.kiasoc5
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-09-24gnu: cbonsai: Update to 1.3.1.Leo Famulari
2021-06-30gnu: cbonsai: Update to 1.2.1.Tobias Geerinckx-Rice
2021-06-28gnu: Add oneko.Timotej Lazar
2021-05-02gnu: Replace hard-coded "CC=gcc" with CC-FOR-TARGET calls.Maxime Devos
2021-03-24gnu: Add cbonsai.Leo Famulari