;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages time) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public time (package (name "time") (version "1.7") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/time/time-" version ".tar.gz")) (sha256 (base32 "0va9063fcn7xykv658v2s9gilj2fq4rcdxx2mn2mmy1v4ndafzp3")))) (build-system gnu-build-system) (arguments '(#:phases (alist-replace 'configure (lambda* (#:key outputs #:allow-other-keys) ;; This old `configure' script doesn't support ;; variables passed as arguments. (let ((out (assoc-ref outputs "out"))) (setenv "CONFIG_SHELL" (which "bash")) (zero? (system* "./configure" (string-append "--prefix=" out))))) %standard-phases))) (home-page "http://www.gnu.org/software/time/") (synopsis "Run a command, then display its resource usage") (description "Time is a command that displays information about the resources that a program uses. The display output of the program can be customized or saved to a file.") (license gpl2+))) 71d2a303b86473f'>packages/bash.scm
AgeCommit message (Expand)Author
2021-12-20gnu: Add bash-with-syslog.Ricardo Wurmus
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-06-04gnu: bats: Set #:guile argument of 'wrap-script'.Maxime Devos
2021-05-09gnu: bash: Update to 5.1.8.Marius Bakke
2020-10-26gnu: Use prefix "license:" to import (guix licenses)Zhu Zihao
2020-10-26gnu: Add bash-ctypes.Zhu Zihao
2020-07-12gnu: Remove ".git" from "https://github/…/….git".Ludovic Courtès
2020-07-10gnu: bats: Define TAP.Tobias Geerinckx-Rice
2020-06-29gnu: Add bats.Oleg Pykhalov
2020-05-22gnu: bash: Do not autoload (gcrypt hash).Ludovic Courtès
2020-05-22packages: Introduce <content-hash> and use it in <origin>.Ludovic Courtès
2020-03-14Merge branch 'master' into core-updatesMarius Bakke
2020-03-10gnu: bash-tap: Use HTTPS home page.Tobias Geerinckx-Rice
2020-02-15gnu: bash: Update to 5.0.16.Marius Bakke
2019-12-31Merge remote-tracking branch 'master' into core-updates.Mathieu Othacehe
2019-12-20gnupg: 'gnupg-verify*' returns a status symbol.Ludovic Courtès
2019-11-27gnu: bash: Update to patch level 11.Efraim Flashner