;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages time) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public time (package (name "time") (version "1.7") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/time/time-" version ".tar.gz")) (sha256 (base32 "0va9063fcn7xykv658v2s9gilj2fq4rcdxx2mn2mmy1v4ndafzp3")))) (build-system gnu-build-system) (arguments '(#:phases (alist-replace 'configure (lambda* (#:key outputs #:allow-other-keys) ;; This old `configure' script doesn't support ;; variables passed as arguments. (let ((out (assoc-ref outputs "out"))) (setenv "CONFIG_SHELL" (which "bash")) (zero? (system* "./configure" (string-append "--prefix=" out))))) %standard-phases))) (home-page "http://www.gnu.org/software/time/") (synopsis "Run a command, then display its resource usage") (description "Time is a command that displays information about the resources that a program uses. The display output of the program can be customized or saved to a file.") (license gpl2+))) 578d8febd6268e0ae439ba'>services/mcron.scm
AgeCommit message (Expand)Author
2020-08-26services: mcron: Validate jobs even in the presence of #:user....Ludovic Courtès
2020-08-26services: mcron: Validate jobs at build time....Ludovic Courtès
2020-01-06Adjust module autoloads....Ludovic Courtès
2019-12-08services: mcron: Add description....Robert Vollmert
2019-06-15services: Remove unneeded imports that led to cycles....Ludovic Courtès
2019-05-12services: mcron: Log to a file....Christopher Baines
2019-01-28gnu: Move most packages from guile.scm to new module....Ricardo Wurmus
2019-01-11services: Deprecate a few more service procedures....Ludovic Courtès
2018-11-13services: mcron: Fix typo in comment....Ludovic Courtès