;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2018 Christopher Baines ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages terraform) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix git-download) #:use-module (guix build-system go)) (define-public terraform-docs (package (name "terraform-docs") (version "0.6.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/segmentio/terraform-docs") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1p6prhjf82qnhf1zwl9h92j4ds5g383a6g9pwwnqbc3wdwy5zx7d")))) (build-system go-build-system) (arguments '(#:import-path "github.com/segmentio/terraform-docs")) (synopsis "Generate documentation from Terraform modules") (description "The @code{terraform-docs} utility can generate documentation describing the inputs and outputs for modules of the Terraform infrastructure management tool. These can be shown, or written to a file in JSON or Markdown formats.") (home-page "https://github.com/segmentio/terraform-docs") (license license:expat))) 36656c60377a369bd7b5'>gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-26 14:19:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-27 17:38:17 +0100
commitd24b3b02133e5e3ccc4236656c60377a369bd7b5 (patch)
tree4b586923c1d8d8590b6c133e134fa2dbe6498669 /gnu
parentfaa0fa3978bad240f245c79aa487e0594ae9fc9a (diff)
downloadguix-d24b3b02133e5e3ccc4236656c60377a369bd7b5.tar.gz
guix-d24b3b02133e5e3ccc4236656c60377a369bd7b5.zip
gnu: rseqc: Update to 3.0.1.
* gnu/packages/bioinformatics.scm (rseqc): Update to 3.0.1. [source]: Remove snippet. [arguments]: Remove to build with Python 3. [inputs]: Replace python2-cython, python2-pysam, and python2-numpy with python-cython, python-pysam, and python-numpy, respectively; add python-bx-python and python-pybigwig. [native-inputs]: Replace python2-nose with python-nose.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm28
1 files changed, 9 insertions, 19 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8ed13b22e5..51ffa00860 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm