;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Alex Kost ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages sxiv) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages xorg) #:use-module (gnu packages image) #:use-module (gnu packages photo)) (define-public sxiv (package (name "sxiv") (version "1.3.1") (source (origin (method url-fetch) (uri (string-append "https://github.com/muennich/sxiv/archive/v" version ".tar.gz")) (file-name (string-append name "-" version ".tar.gz")) (sha256 (base32 "03hxy5ff7xbs15rhlbpgx8xmvmpjlffp0m4528975hg16sqa2c4s")))) (build-system gnu-build-system) (arguments '(#:tests? #f ; no check target #:make-flags (list (string-append "PREFIX=" %output) "CC=gcc") #:phases (alist-delete 'configure ; no configure phase %standard-phases))) (inputs `(("libx11" ,libx11) ("imlib2" ,imlib2) ("giflib" ,giflib) ("libexif" ,libexif))) (home-page "https://github.com/muennich/sxiv") (synopsis "Simple X Image Viewer") (description "sxiv is an alternative to feh and qiv. Its primary goal is to provide the most basic features required for fast image viewing. It has vi key bindings and works nicely with tiling window managers. Its code base should be kept small and clean to make it easy for you to dig into it and customize it for your needs.") (license license:gpl2+))) tent'>
AgeCommit message (Expand)Author
2020-11-07linux-boot: Resume from hibernation....Tobias Geerinckx-Rice
2020-09-07linux-boot: Handle nfs-root device strings....Stefan
2020-06-08hurd-boot: Further cleanup of "rc"....Jan (janneke) Nieuwenhuizen
2020-06-08linux-boot: Update 'make-hurd-device-nodes'....Jan (janneke) Nieuwenhuizen
2020-05-20linux-boot: Refactor boot-system....Maxim Cournoyer
2020-05-02Merge branch 'master' into core-updatesMarius Bakke
2020-05-02linux-boot: Allow the root file system to be mounted via NFS....Stefan
2020-04-11linux-boot: Add 'make-hurd-device-nodes'....Ludovic Courtès
2020-04-11linux-boot: 'make-essential-device-nodes' root parameter is optional....Ludovic Courtès
2020-03-02linux-boot: Ensure volatile root is mounted read-only....Maxim Cournoyer
2019-12-12linux-boot: Don't ignore flags when mounting root file system....Guillaume Le Vaillant
2019-11-18linux-boot: Don't ignore options when mounting root file system....Guillaume Le Vaillant
2019-11-18linux-boot: Fix indentation....Maxim Cournoyer
2019-09-25linux-boot: Fix typo....Maxim Cournoyer
2019-08-16linux-modules: Add 'load-linux-modules-from-directory'....Ludovic Courtès
2019-06-03linux-boot: Fix e2fsck warning....Danny Milosavljevic
2019-03-24system: Initialize console keyboard layout in the initrd....Ludovic Courtès