;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Alex Kost ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages sxiv) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages xorg) #:use-module (gnu packages image) #:use-module (gnu packages photo)) (define-public sxiv (package (name "sxiv") (version "1.3.1") (source (origin (method url-fetch) (uri (string-append "https://github.com/muennich/sxiv/archive/v" version ".tar.gz")) (file-name (string-append name "-" version ".tar.gz")) (sha256 (base32 "03hxy5ff7xbs15rhlbpgx8xmvmpjlffp0m4528975hg16sqa2c4s")))) (build-system gnu-build-system) (arguments '(#:tests? #f ; no check target #:make-flags (list (string-append "PREFIX=" %output) "CC=gcc") #:phases (alist-delete 'configure ; no configure phase %standard-phases))) (inputs `(("libx11" ,libx11) ("imlib2" ,imlib2) ("giflib" ,giflib) ("libexif" ,libexif))) (home-page "https://github.com/muennich/sxiv") (synopsis "Simple X Image Viewer") (description "sxiv is an alternative to feh and qiv. Its primary goal is to provide the most basic features required for fast image viewing. It has vi key bindings and works nicely with tiling window managers. Its code base should be kept small and clean to make it easy for you to dig into it and customize it for your needs.") (license license:gpl2+))) ommit/gnu/packages/machine-learning.scm?id=8a1716fe3f69462eb0d436ff29bb8c17e799b0f5'>machine-learning.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-01 21:36:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:16:33 +0300
commit8a1716fe3f69462eb0d436ff29bb8c17e799b0f5 (patch)
tree57173140e985012b8436249499ff9a1b458a60a0 /gnu/packages/machine-learning.scm
parent4ac8d4864035d753429265a637b197356df8017b (diff)
downloadguix-8a1716fe3f69462eb0d436ff29bb8c17e799b0f5.tar.gz
guix-8a1716fe3f69462eb0d436ff29bb8c17e799b0f5.zip
gnu: curl: Update to 7.55.0.
* gnu/packages/curl.scm (curl): Update to 7.55.0. [replacement]: Remove field. [arguments]: Add phase to fix doc install location. (curl-7.55.0): Remove variable.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
0 files changed, 0 insertions, 0 deletions