;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Eric Bavier ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages serveez) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages) #:use-module (gnu packages guile)) (define-public serveez (package (name "serveez") (version "0.2.2") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/serveez/serveez-" version ".tar.xz")) (sha256 (base32 "09a5jh762ps71ivlg7vdlzp3y29ncl3nsad7qbcni78bq2mzwxsc")))) (build-system gnu-build-system) (inputs `(("guile" ,guile-2.0))) (arguments `(#:configure-flags '("--enable-libserveez-install") #:phases (modify-phases %standard-phases (add-before 'patch-source-shebangs 'patch-test-source (lambda _ (substitute* (find-files "test" "^t[0-9]{3}$") (("/bin/sh") (which "sh"))) #t))))) (home-page "https://www.gnu.org/software/serveez/") (synopsis "Framework for implementing IP-based servers") (description "GNU Serveez is a server framework providing the routines necessary to easily implement IP-based servers in your application. It demonstrates aspects of network programming in a portable manner, making it convenient for both simplifying the process of adding a server to your application or for learning about how network services work. Several example servers are provided already, such as an HTTP server and an IRC server.") (license gpl3+))) d171cf903a69949fce'>gnupg.scm
href='/guix/commit/po/doc/local.mk?id=7bc46ecc34ceb042ff890e5d306d0a2a736e891d'>doc: Add Guix Cookbook....
AgeCommit message (Expand)Author
2018-10-16gnu: guile2.0-guix: Fix build....Eric Bavier
Ricardo Wurmus
2019-05-13doc: Add Russian translation....Ludovic Courtès
2019-04-30build: 'guix-manual.*.po' no longer depends on 'guix-manual.pot'....Ludovic Courtès
2019-04-29maint: Mark 'doc-pot-update' and 'doc-po-update' as phony....Ludovic Courtès
2019-04-24doc: Add Simplified Chinese translation....Ludovic Courtès
2019-04-23doc: Add Spanish translation....Miguel Ángel Arruga Vivas
2018-11-28nls: Update documentation po and pot with `make dist`....Julien Lepiller
2018-11-01doc: Add German translation....Julien Lepiller