;;; GNU Guix --- Functional package management for GNU ;;; Copyright 2014 John Darrington ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages scanner) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix licence:)) (define-public sane-backends (package (name "sane-backends") (version "1.0.24") (source (origin (method url-fetch) (uri (string-append "https://alioth.debian.org/frs/download.php/file/3958/" name "-" version ".tar.gz")) (sha256 (base32 "0ba68m6bzni54axjk15i51rya7hfsdliwvqyan5msl7iaid0iir7")))) (build-system gnu-build-system) (arguments `(#:tests? #f)) ;; It would seem that tests are not maintained - fails with ;; the following: ;; ;; < This page was last updated on Wed Jul 31 07:52:48 2013 ;; < by sane-desc 3.5 from sane-backends 1.0.24git ;; --- ;; > This page was last updated on Sun Oct 19 15:41:39 2014 ;; > by sane-desc 3.5 from sane-backends 1.0.24 ;; **** File generated for html-backends-split mode is different from reference ;; Makefile:501: recipe for target 'check.local' failed (home-page "http://www.sane-project.org") (synopsis "Raster image scanner library and drivers") (description "SANE stands for \"Scanner Access Now Easy\" and is an API proving access to any raster image scanner hardware (flatbed scanner, hand-held scanner, video- and still-cameras, frame-grabbers, etc.). The package contains the library and drivers.") (license licence:gpl2+))) ; plus linking exception nu/packages/flashing-tools.scm?id=560062aaeabb485e7f53f8f5e6449b9a35aa9ca2'>flashing-tools.scm
AgeCommit message (Expand)Author
2023-11-24gnu: uuu: Update to 1.5.125.Mathieu Othacehe
2023-10-10gnu: Add teensy-udev-rules.Maxim Cournoyer
2023-10-10gnu: teensy-loader-cli: Fix license.Maxim Cournoyer
2023-10-10gnu: teensy-loader-cli: Use gexps.Maxim Cournoyer
2023-09-27gnu: Add qdl.B. Wilson
2023-09-02gnu: teesy-loader-cli: Drop trailing #t.Maxim Cournoyer
2023-07-16gnu: srecord: Update to 1.65.0.Tobias Geerinckx-Rice
2023-06-08gnu: flashrom: Wrap PATH to find dmidecode.Hilton Chain
2023-06-08gnu: flashrom: Update to 1.3.0.Hilton Chain
2023-02-19gnu: Use HTTPS package home pages wherever possible.Tobias Geerinckx-Rice
2022-12-11gnu: flashrom: Fix build on AArch64.Simon South