;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013, 2016 Ludovic Courtès ;;; Copyright © 2022 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages rush) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses) #:use-module (gnu packages)) (define-public rush (package (name "rush") (version "2.2") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/rush/rush-" version ".tar.gz")) (sha256 (base32 "1kcqilbcvxsh89196ryh3p9zh4b266517q9681mjmckvj5v57plm")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/rush/") (synopsis "Restricted user (login) shell") (description "GNU Rush is a restricted user shell, for systems on which users are to be provided with only limited functionality or resources. Administrators set user rights via a configuration file which can be used to limit, for example, the commands that can be executed, CPU time, or virtual memory usage.") (license gpl3+))) /option>
diff options
context:
space:
mode:
authorIvan Petkov <ivanppetkov@gmail.com>2019-04-02 03:02:51 -0700
committerChris Marusich <cmmarusich@gmail.com>2019-04-09 03:09:00 -0700
commit1d3acde5087d50af6a4901fd7614f0940eb7b41d (patch)
treeaf0447b8e6ebd2c1035e06627c6d28f509a74065 /tests/guix-gc.sh
parent23635b2ee95c2deb5041329fc2124636319a6333 (diff)
downloadguix-1d3acde5087d50af6a4901fd7614f0940eb7b41d.tar.gz
guix-1d3acde5087d50af6a4901fd7614f0940eb7b41d.zip
build-system/cargo: refactor phases to successfully build
* guix/build-system/cargo.scm (%cargo-build-system-modules): Add (json parser). (cargo-build): [vendor-dir]: Define flag and pass it to builder code. [cargo-test-flags]: Likewise. [skip-build?]: Likewise. * guix/build/cargo-build/system.scm (#:use-module): use (json parser). (package-name->crate-name): Delete it. (manifest-targets): Add it. (has-executable-target?): Add it. (configure): Add #:vendor-dir name and use it. Don't touch Cargo.toml. Don't symlink to duplicate inputs. Remove useless registry line from cargo config. Define RUSTFLAGS to lift lint restrictions. (build): Add #:skip-build? flag and use it. (check): Likewise. Add #:cargo-test-flags and pass it to cargo. (install): Factor source logic to install-source. Define #:skip-build? flag and use it. Only install if executable targets are present. (install-source): Copy entire crate directory not just src. [generate-checksums] pass dummy file for unused second argument. (%standard-phases): Add install-source phase. Signed-off-by: Chris Marusich <cmmarusich@gmail.com>
Diffstat (limited to 'tests/guix-gc.sh')
0 files changed, 0 insertions, 0 deletions