;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013, 2016 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages rush) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses) #:use-module (gnu packages)) (define-public rush (package (name "rush") (version "1.8") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/rush/rush-" version ".tar.gz")) (sha256 (base32 "1vxdb81ify4xcyygh86250pi50krb16dkj42i5ii4ns3araiwckz")))) (build-system gnu-build-system) (home-page "http://www.gnu.org/software/rush/") (synopsis "Restricted user (login) shell") (description "GNU Rush is a restricted user shell, for systems on which users are to be provided with only limited functionality or resources. Administrators set user rights via a configuration file which can be used to limit, for example, the commands that can be executed, CPU time, or virtual memory usage.") (license gpl3+))) den' name='showmsg' value='1'/>
AgeCommit message (Collapse)Author
2020-08-01gnu: Update xxhash to 0.8.0.Hendursaga
* gnu/packages/digest.scm (xxhash): Update to 0.8.0. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
2020-06-29gnu: xxhash: Detect vector instructions at run time.Tobias Geerinckx-Rice
* gnu/packages/digest.scm (xxhash)[arguments]: Set DISPATCH=1 make flag on x86.
2020-06-29gnu: xxhash: Update to 0.7.4.Tobias Geerinckx-Rice
* gnu/packages/digest.scm (xxhash): Update to 0.7.4.
2020-06-29gnu: xxhash: Cross-compile.Tobias Geerinckx-Rice
* gnu/packages/digest.scm (xxhash)[arguments]: Use CC-FOR-TARGET.
2020-03-11gnu: xxHash: Update to 0.7.3.Leo Famulari
* gnu/packages/digest.scm (xxhash): Update to 0.7.3.
2019-12-23gnu: xxhash: Update to 0.7.2.Tobias Geerinckx-Rice
* gnu/packages/digest.scm (xxhash): Update to 0.7.2. [arguments]: Run ‘make check’ in parallel.
2019-11-10gnu: Add 'file-name' where appropriate.Efraim Flashner
* gnu/packages/admin.scm (detox, neofetch), gnu/packages/algebra.scm (python-fpylll), gnu/packages/bioinformatics.scm (tbsp, genrich), gnu/packages/crypto.scm (hpenc), gnu/packages/digest.scm (xxhash), gnu/packages/emacs-xyz.scm (emacs-tiny, emacs-ergoemacs-mode, emacs-make-it-so, emacs-poet-theme, emacs-deft, emacs-scribble-mode, emacs-helm-mu, emacs-unidecode, emacs-diff-hl, emacs-helm-exwm, emacs-gif-screencast, emacs-exec-path-from-shell), gnu/packages/engineering.scm (gpx), gnu/packages/freedesktop.scm (waylandpp), gnu/packages/golang.scm (go-github-com-sirupsen-logrus, go-github-com-shirou-gopsutil), gnu/packages/guile-xyz.scm (guile-studio, guile-picture-language, jupyter-guile-kernel), gnu/packages/image-viewers.scm (qview), gnu/packages/java-maths.scm (java-jblas), gnu/packages/llvm.scm (libclc), gnu/packages/logging.scm (spdlog), gnu/packages/ocaml.scm (ocaml-cstruct, ocaml-zarith), gnu/packages/terminals.scm (libtsm), gnu/packages/tigervnc.scm (tigervnc-client), gnu/packages/xdisorg.scm (xcalib, xbanish) [source]: Add file-name.