;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2017 Sergei Trofimovich ;;; Copyright © 2018 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages re2c) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public re2c (package (name "re2c") (version "1.1.1") (source (origin (method url-fetch) (uri (string-append "https://github.com/skvadrik/" name "/releases/download/" version "/" name "-" version ".tar.gz")) (sha256 (base32 "1ksifjn18v6nra935dpqllmvkqgcdsggfjgmj77282x0gqrrfrc5")))) (build-system gnu-build-system) (home-page "http://re2c.org/") (synopsis "Lexer generator for C/C++") (description "@code{re2c} generates minimalistic hard-coded state machine (as opposed to full-featured table-based lexers). Flexible API allows generated code to be wired into virtually any environment. Instead of exposing traditional @code{yylex()} style API, re2c exposes its internals. Be sure to take a look at examples, they cover a lot of real-world cases and shed some light on dark corners of re2c API.") (license public-domain))) ix/log/?id=958f6b5aa6c7bad87105384c0fb3920c01590a5f'>root/tests/pypi.scm
AgeCommit message (Expand)Author
2020-07-25utils: Remove compatibility re-export of 'memoize'....Ludovic Courtès
2020-04-27tests: Remove trailing commas in JSON tests....Ludovic Courtès
2020-03-12import: pypi: Rewrite to use 'define-json-mapping'....Ludovic Courtès
2019-07-02import: pypi: Include optional test inputs as native-inputs....Maxim Cournoyer
2019-07-02import: pypi: Parse wheel METADATA instead of metadata.json....Maxim Cournoyer
2019-07-02import: pypi: Support more types of archives....Maxim Cournoyer
2019-07-02import: pypi: Improve parsing of requirement specifications....Maxim Cournoyer
2019-07-02import: pypi: Do not parse optional requirements from source....Maxim Cournoyer
2019-07-02tests: pypi: Mute the output of tar....Maxim Cournoyer
2019-07-02import: pypi: Do not consider requirements.txt files....Maxim Cournoyer
2018-10-18gnu: Use pypi.org....Leo Famulari
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2018-07-24import: PyPI: Update redirected URL....Marius Bakke
2017-06-18import: pypi: Adjust URIs in tests....Ludovic Courtès