;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Ricardo Wurmus ;;; Copyright © 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ragel) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages)) (define-public ragel (package (name "ragel") (version "6.10") (source (origin (method url-fetch) (uri (string-append "https://www.colm.net/files/ragel/ragel-" version ".tar.gz")) (sha256 (base32 "0gvcsl62gh6sg73nwaxav4a5ja23zcnyxncdcdnqa2yjcpdnw5az")))) (build-system gnu-build-system) (home-page "https://www.colm.net/open-source/ragel/") (synopsis "State machine compiler") (description "Ragel compiles executable finite state machines from regular languages. Ragel targets C, C++, Obj-C, C#, D, Java, Go and Ruby. Ragel state machines can not only recognize byte sequences as regular expression machines do, but can also execute code at arbitrary points in the recognition of a regular language. Code embedding is done using inline operators that do not disrupt the regular language syntax.") ;; GPLv2 (or later) with exception for generated code. (license license:gpl2+))) 6815ffdd48bd2aec89b4cc4e9'>root/gnu/packages/llvm.scm
AgeCommit message (Expand)Author
2017-05-10gnu: Add LLVM, CLANG 3.9.1....Roel Janssen
2017-05-04gnu: llvm-3.5: Fix build of clang-3.5....Ricardo Wurmus
2017-01-02gnu: Disambiguate packages with the same name....Ludovic Courtès
2016-12-14gnu: llvm: Enable install utils....David Craven
2016-11-08gnu: Add LLVM variant with RTTI support....Ricardo Wurmus
2016-09-21gnu: extempore: Only build on x86_64....Ricardo Wurmus
2016-09-16gnu: Add llvm-for-extempore....Ricardo Wurmus
2016-09-09gnu: llvm: Build shared libraries....Eric Bavier
2016-09-09gnu: llvm: propagate zlib input....Eric Bavier
2016-07-18gnu: llvm: Build without debugging symbols....Eric Bavier
2016-07-18gnu: llvm: Update to 3.8.1....Eric Bavier
2016-07-18gnu: llvm: Update to 3.7.1....Eric Bavier
2016-07-18gnu: llvm: Add libffi and zlib inputs....Eric Bavier
2016-07-18gnu: llvm: Add "license:" prefix....Eric Bavier
2016-07-18gnu: llvm: Update to 3.5.2....Eric Bavier
2016-04-14gnu: packages: Use 'search-patches' everywhere....Alex Kost
2015-11-04gnu: clang-runtime: Mark MIPS as unsupported....Ludovic Courtès