;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Claes Wallin ;;; Copyright © 2021 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages pv) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public pv (package (name "pv") (version "1.6.20") (source (origin (method url-fetch) (uri (string-append "https://www.ivarch.com/programs/sources/pv-" version ".tar.bz2")) (sha256 (base32 "00y6zla8h653sn4axgqz7rr0x79vfwl62a7gn6lzn607zwg9acg8")))) (build-system gnu-build-system) (home-page "https://www.ivarch.com/programs/pv.shtml") (synopsis "Pipeline progress indicator") (description "@acronym{pv, Pipe Viewer} is a terminal tool for monitoring the progress of data through a pipeline. It can be inserted into any normal pipeline between two processes. It gives a visual indication of how quickly data is passing through, how much has been transferred and how near to completion it is (with a progress bar), how long it has taken, and an estimate of the remaining time before completion.") (license artistic2.0))) alue=''/>
tr>
AgeCommit message (Expand)Author
2019-03-01gnu: acl: Update to 2.2.53....Marius Bakke
2018-03-16gnu: acl: Use invoke instead of system*....Mark H Weaver
2018-03-15gnu: acl: Fix build failure....Ricardo Wurmus
2018-02-16Merge branch 'master' into core-updatesMark H Weaver
2018-02-16gnu: Use HTTPS for supported nongnu.org home pages....Tobias Geerinckx-Rice
2016-07-12gnu: Switch to 'with-imported-modules'....Ludovic Courtès
2016-02-08linux-container: Accept file systems with a UUID 'source'....Ludovic Courtès
2016-02-08file-systems: Spawn a Bournish REPL upon fsck failure....Ludovic Courtès
2015-11-02services: Add 'system-service-type'....Ludovic Courtès
2015-10-30scripts: system: Add 'container' action....David Thompson
2015-10-30system: container: Adjust to changes in gexps....David Thompson
2015-09-14gnu: system: Add Linux container module....David Thompson