;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès ;;; Copyright © 2014, 2015, 2016 Mark H Weaver ;;; Copyright © 2016 Efraim Flashner ;;; Copyright © 2016 Ricardo Wurmus ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages pu
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-06 11:17:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-06 12:31:07 +0100
commit6448c2e156fed5b2e9375f0ae378fbbce38ffb36 (patch)
treedc4a1b2fd2bb916b452e90c5ca6a6136c170d06f /scripts
parentdd386dd74fab86e7177876f0f24e2891b83736d0 (diff)
downloadguix-6448c2e156fed5b2e9375f0ae378fbbce38ffb36.tar.gz
guix-6448c2e156fed5b2e9375f0ae378fbbce38ffb36.zip
gnu: libgit2-glib: Update to 0.99.0.1.
* gnu/packages/gnome.scm (libgit2-glib): Update to 0.99.0.1. [native-inputs]: Remove INTLTOOL.
Diffstat (limited to 'scripts')
0 files changed, 0 insertions, 0 deletions
(assoc-ref %outputs "out") "/lib/udev/rules.d")) #:phases (alist-cons-before 'check 'pre-check (lambda _ ;; 'tests/lock-autospawn-test.c' wants to create a file ;; under ~/.config/pulse. (setenv "HOME" (getcwd)) ;; 'thread-test' needs more time on hydra and on slower ;; machines, so we set the default timeout to 120 seconds. (setenv "CK_DEFAULT_TIMEOUT" "120")) %standard-phases))) (inputs ;; TODO: Add optional inputs (GTK+?). `(("alsa-lib" ,alsa-lib) ("bluez" ,bluez) ("sbc" ,sbc) ("json-c" ,json-c) ("speex" ,speex) ("libsndfile" ,libsndfile) ("libsamplerate" ,libsamplerate) ("dbus" ,dbus) ("glib" ,glib) ("intltool" ,intltool) ("m4" ,m4) ("libltdl" ,libltdl) ("fftwf" ,fftwf) ("avahi" ,avahi) ("eudev" ,eudev) ;for the detection of hardware audio devices ("check" ,check))) (native-inputs `(("pkg-config" ,pkg-config))) (propagated-inputs ;; 'libpulse*.la' contain `-lgdbm' and `-lcap', so propagate them. `(("libcap" ,libcap) ("gdbm" ,gdbm))) (home-page "http://www.pulseaudio.org/") (synopsis "Sound server") (description "PulseAudio is a sound server. It is basically a proxy for your sound applications. It allows you to do advanced operations on your sound data as it passes between your application and your hardware. Things like transferring the audio to a different machine, changing the sample format or channel count and mixing several sounds into one are easily achieved using a sound server.") ;; PulseAudio is LGPLv2+, but some of the optional dependencies (GNU dbm, ;; FFTW, etc.) are GPL'd, so the result is effectively GPLv2+. See ;; 'LICENSE' for details. (license l:gpl2+))) (define-public pavucontrol (package (name "pavucontrol") (version "3.0") (source (origin (method url-fetch) (uri (string-append "https://freedesktop.org/software/pulseaudio/pavucontrol/pavucontrol-" version ".tar.xz")) (sha256 (base32 "14486c6lmmirkhscbfygz114f6yzf97h35n3h3pdr27w4mdfmlmk")))) (build-system gnu-build-system) (arguments '(#:configure-flags '("CXXFLAGS=-std=c++11"))) ; required by gtkmm (inputs `(("libcanberra" ,libcanberra) ("gtkmm" ,gtkmm) ("pulseaudio" ,pulseaudio))) (native-inputs `(("intltool" ,intltool) ("pkg-config" ,pkg-config))) (home-page "http://freedesktop.org/software/pulseaudio/pavucontrol/") (synopsis "PulseAudio volume control") (description "PulseAudio Volume Control (pavucontrol) provides a GTK+ graphical user interface to connect to a PulseAudio server and easily control the volume of all clients, sinks, etc.") (license l:gpl2+)))