;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2015 Ludovic Courtès ;;; Copyright © 2014 Mark H Weaver ;;; Copyright © 2017 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages pth) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public pth (package (name "pth") (version "2.0.7") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/pth/pth-" version ".tar.gz")) (sha256 (base32 "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj")))) (build-system gnu-build-system) (arguments `(#:parallel-build? #f #:configure-flags (list ,@(if (string=? "aarch64-linux" (%current-system)) '("--host=aarch64-unknown-linux-gnu") '())))) (home-page "https://www.gnu.org/software/pth/") (synopsis "Portable thread library") (description "GNU Pth is a portable library providing non-preemptive, priority-based scheduling for multiple execution threads. Each thread has its own program-counter, run-time stack, signal mask and errno variable. Threads are scheduled in a cooperative way, rather than in the standard preemptive way, such that they are managed according to priority and events. However, Pth also features emulation of POSIX.1c threads (\"pthreads\") for backwards compatibility.") (license lgpl2.1+))) ba5385d48d4923f68f86f40256add6b41d'>mail.scm
AgeCommit message (Expand)Author
2020-03-16tests: opensmtpd: Check /var/spool/mail instead of /var/mail....Ludovic Courtès
2020-03-16tests: opensmtpd: Gracefully handle test failure....Ludovic Courtès
2020-03-09tests: getmail: Provide a pre-initialized user account password....Ludovic Courtès
2020-01-31gnu: Update opensmtpd configuration grammar....Tobias Geerinckx-Rice
2020-01-20tests: mail: Remove %getmail-os from the bottom of the file....Christopher Baines
2019-06-19tests: Fix opensmtpd test....Tobias Geerinckx-Rice
2019-05-31services: Add getmail....Christopher Baines
2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....Ludovic Courtès
2018-06-13tests: Honor the return value of 'start-service'....Clément Lassieur
2018-03-09tests: mail: Add test for dovecot....Oleg Pykhalov
2017-07-20tests: Use 'virtual-machine' records instead of monadic procedures....Ludovic Courtès
2017-04-19tests: mail: Add test for exim...Carlo Zancanaro
2017-04-01tests: Introduce 'simple-operating-system' and use it....Ludovic Courtès