;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2015 Ludovic Courtès ;;; Copyright © 2014 Mark H Weaver ;;; Copyright © 2017 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages pth) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public pth (package (name "pth") (version "2.0.7") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/pth/pth-" version ".tar.gz")) (sha256 (base32 "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj")))) (build-system gnu-build-system) (arguments `(#:parallel-build? #f #:configure-flags (list ,@(if (string=? "aarch64-linux" (%current-system)) '("--host=aarch64-unknown-linux-gnu") '())))) (home-page "https://www.gnu.org/software/pth/") (synopsis "Portable thread library") (description "GNU Pth is a portable library providing non-preemptive, priority-based scheduling for multiple execution threads. Each thread has its own program-counter, run-time stack, signal mask and errno variable. Threads are scheduled in a cooperative way, rather than in the standard preemptive way, such that they are managed according to priority and events. However, Pth also features emulation of POSIX.1c threads (\"pthreads\") for backwards compatibility.") (license lgpl2.1+))) nu/packages/cups.scm?id=9b29c5422e6d99327566c56254e1328b1b40fe0c'>cups.scm
AgeCommit message (Expand)Author
2022-01-10gnu: cups-minimal: Remove obsolete phase....Sarah Morgensen
2021-12-13gnu: Simplify package inputs....Ludovic Courtès
2021-11-23Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-18gnu: foo2zjs: Use archived home page....Tobias Geerinckx-Rice
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-08gnu: packages: Remove last year's deprecations....Tobias Geerinckx-Rice
2021-11-08Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner
2021-11-08gnu: hplip: Update to 3.21.10....Tobias Geerinckx-Rice
2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe
2021-09-27gnu: foomatic-filters: Fix build....Mathieu Othacehe
2021-09-18gnu: hplip: Update to 3.21.8....Tobias Geerinckx-Rice
2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-09-04gnu: epson-inkjet-printer-escpr: Update to 1.7.17....Tobias Geerinckx-Rice
2021-09-03gnu: hplip: Update to 3.21.6....Tobias Geerinckx-Rice