;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages protobuf) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:select (bsd-3)) #:use-module (gnu packages compression)) (define-public protobuf (package (name "protobuf") (version "2.5.0") (source (origin (method url-fetch) (uri (string-append "http://protobuf.googlecode.com/files/protobuf-" version ".tar.bz2")) (sha256 (base32 "0xxn9gxhvsgzz2sgmihzf6pf75clr05mqj6218camwrwajpcbgqk")))) (build-system gnu-build-system) (inputs `(("zlib" ,zlib))) (home-page "http://code.google.com/p/protobuf/") (synopsis "Data encoding for remote procedure calls (RPCs)") (description "Protocol Buffers are a way of encoding structured data in an efficient yet extensible format. Google uses Protocol Buffers for almost all of its internal RPC protocols and file formats.") (license bsd-3))) tion>
9ff4455703536788d536e4e7cfb4ee285002'>gnu: Remove the various Go union meta-packages.
AgeCommit message (Expand)Author
2023-08-21tests: Adjust 'node-back-edges' test for 'bag' to system-dependent glibc.Ludovic Courtès
2023-04-07gnu: Purge pre-1.3.0 deprecated packages.Bruno Victal
2022-10-22Remove now unnecessary uses of (guix grafts).Ludovic Courtès
2022-07-01tests: Adjust 'guix graph' test to latest OCaml changes.Ludovic Courtès
2022-02-05tests: Assert that cyclic graphs can be produced.Liliana Marie Prikler
2021-09-21graph: Add '--max-depth'.Ludovic Courtès
2020-10-20graph: Adjust test for recent OCaml changes.Ludovic Courtès
Leo Famulari
2019-02-04gnu: gx, go-github-com-whyrusleeping-gx-util: Update to 0.14.1.Tobias Geerinckx-Rice
2018-12-13gnu: go-ipfs: Work around tar bomb.Ludovic Courtès
2018-12-09gnu: Add go-ipfs.Pierre Neidhardt
2018-10-24gnu: Add gx-go.Pierre Neidhardt
2018-10-24gnu: Add go-github-com-whyrusleeping-gx-util.Pierre Neidhardt
2018-10-24gnu: Add gx.Pierre Neidhardt
2018-10-24gnu: Add go-github-com-ipfs-go-ipfs-api.Pierre Neidhardt
2018-10-24gnu: Add go-github-com-ipfs-go-ipfs-cmdkit-files.Pierre Neidhardt