;;; Copyright © 2020 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages presentation) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix download) #:use-module (guix packages) #:use-module (guix utils) #:use-module (guix build-system python) #:use-module (gnu packages bash) #:use-module (gnu packages figlet) #:use-module (gnu packages games) #:use-module (gnu packages image) #:use-module (gnu packages python) #:use-module (gnu packages python-xyz)) (define-public presentty (package (name "presentty") (version "0.2.1") (source (origin (method url-fetch) (uri (pypi-uri "presentty" version)) (sha256 (base32 "1qpy992hyg1amjl0acic3agj20spcpv5m0ncg1283mmxs8cs3xy9")) (patches (list (origin (method url-fetch) (uri "https://sources.debian.org/data/main/p/presentty/0.2.1-1/debian/patches/presentty-python3.patch") (sha256 (base32 "03d3ylh1z99g4dqj7aka60spagnwss9mbacd7jbpk1gazflnssz1"))))))) (build-system python-build-system) (arguments `(#:tests? #f ; Test suite hasn't withstood the test of time. #:phases (modify-phases %standard-phases (add-after 'unpack 'loosen-requirements (lambda _ ;; Remove version pinning. (substitute* "requirements.txt" (("pbr>=.*") "pbr")))) (replace 'wrap (lambda* (#:key python inputs outputs #:allow-other-keys) (let* ((out (assoc-ref outputs "out")) (bin (string-append out "/bin/")) (python (assoc-ref inputs "python"))) (for-each (lambda (program) (wrap-program (string-append bin program) `("PATH" ":" prefix (,(dirname (which "cowsay")) ,(dirname (which "figlet")) ,(dirname (which "jp2a")))) `("GUIX_PYTHONPATH" prefix ,(cons (string-append out "/lib/python" (python-version python) "/site-packages") (search-path-as-string->list (or (getenv "GUIX_PYTHONPATH") "")))))) '("presentty" "presentty-console"))))) ;; XXX: console import test fails to find palette.py from the lib? (delete 'sanity-check)))) (inputs (list bash-minimal cowsay figlet jp2a python-docutils python-pillow-2.9 python-six python-urwid)) (native-inputs (list python-pbr python-pygments)) (home-page "http://git.inaugust.com/cgit/presentty/") (synopsis "Console-based presentation system") (description "Presentty is a console-based presentation program where slides are authored in reStructuredText. Its features include, but are not limited to: Cross-fade animations, progressive list display, panning transitions, syntax highlighting, Cowsay and figlet integration, ANSI art, JPEG display.") (license license:gpl3+))) /tr> parenta7d1b8832a465c58e6beba1a030030b232d563ea (diff)downloadguix-9f2c8b711bcd0d059fcca882ee188d0fd03f041c.tar.gz
guix-9f2c8b711bcd0d059fcca882ee188d0fd03f041c.zip
gnu: r-biotip: Update to 1.16.0.
* gnu/packages/bioconductor.scm (r-biotip): Update to 1.16.0. Change-Id: I73503554b0271e5fe950c6da367b4893972f27e9
-rw-r--r--gnu/packages/bioconductor.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3e121f4637..ab12c2ef0c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -22822,14 +22822,14 @@ optimised for high performance.")
(define-public r-biotip
(package
(name "r-biotip")
- (version "1.14.0")
+ (version "1.16.0")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "BioTIP" version))
(sha256
(base32
- "0lqnxaycrva2092h4swmk6na2pq2kp951dmicyw399djd1i7yj50"))))
+ "1bbjfv3bi20xlk8h7r5ipav6mfs27lmj0zjb5mk1gmp071dmnk0y"))))
(properties `((upstream-name . "BioTIP")))
(build-system r-build-system)
(propagated-inputs