;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2019 Julien Lepiller ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages php-xyz) #:use-module (gnu packages) #:use-module (gnu packages php) #:use-module (guix packages) #:use-module (guix git-download) #:use-module (guix build-system copy) #:use-module (guix utils) #:use-module ((guix licenses) #:prefix license:)) (define-public composer-classloader (package (name "composer-classloader") (version "1.9.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/composer/composer") (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "0127zmmg3yx84ljngfs86q7kjhyypybkf4d1ihfrfnzgynzxfxdf")))) (build-system copy-build-system) (arguments `(#:install-plan '(("src/Composer/Autoload/ClassLoader.php" "/share/web/composer/")))) (home-page "https://getcomposer.org") (synopsis "PHP class loader extracted from the composer package") (description "This package contains the class loader class used by Composer to build its autoloading feature. This package is used by the composer-build-system to build its own store-aware autoloading feature.") (license license:expat))) rch'/>
AgeCommit message (Expand)Author
2023-06-26gnu: nvc: Update to 1.9.2.Danny Milosavljevic
2023-02-19gnu: Use HTTPS package home pages wherever possible.Tobias Geerinckx-Rice
2023-02-11gnu: yosys: Update to 0.26.Simon South
2023-02-11gnu: yosys: Do not propagate any inputs.Simon South
2023-02-08gnu: yosys: Use external abc.Simon South
2023-02-08gnu: yosys: Use new package style.Simon South
2023-02-08gnu: yosys: Update source and home-page URLs.Simon South
2023-02-02gnu: nvc: Update to 1.8.1.Danny Milosavljevic
2022-12-27gnu: abc: Update to 0.0-2.70cb339.Simon South
2022-12-27gnu: abc: Use gexps.Simon South
2022-12-27gnu: abc: Convey license information.Simon South
2022-11-03gnu: nvc: Update to 1.7.2.Danny Milosavljevic
2022-10-11gnu: gtkwave: Update to 3.3.113.jgart
2022-09-16gnu: Add openfpgaloader.Danny Milosavljevic
2022-09-02gnu: Add fftgen.Gabriel Wicki
2022-08-17gnu: icestorm: Update to 0.0-4.2bc5417.宋文武