;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2015 Eric Bavier ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice ;;; Copyright © 2017 Petter ;;; Copyright © 2017, 2019 Efraim Flashner ;;; Copyright © 2020 Maxim Cournoyer ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should ha
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-09-10 21:58:25 -0400
committerMark H Weaver <mhw@netris.org>2016-09-10 22:11:21 -0400
commit7c1fedd0d77d2eceb771def8292f364c47e414eb (patch)
treee3ba5f3453daf78052855beea469b4e1b3ba9fc7
parent5ed67c812fe5a83f7c5c0b243258b8f88bde7822 (diff)
downloadguix-7c1fedd0d77d2eceb771def8292f364c47e414eb.tar.gz
guix-7c1fedd0d77d2eceb771def8292f364c47e414eb.zip
gnu: linux-libre: Update to 4.7.3.
* gnu/packages/linux.scm (linux-libre): Update to 4.7.3.
soc-ref %build-inputs "zlib"))) (list (format #f "LIBS=-L~a/lib/ -lz" zlib))))) (inputs `(("zlib" ,zlib))) (home-page "https://metacpan.org/pod/PerlIO::gzip") (synopsis "Perl extension to provide a PerlIO layer to gzip/gunzip") (description "PerlIO::gzip provides a PerlIO layer that manipulates files in the format used by the @command{gzip} program.") (license license:perl-license))) (define-public perl-archive-extract (package (name "perl-archive-extract") (version "0.82") (source (origin (method url-fetch) (uri (string-append "mirror://cpan/authors/id/B/BI/BINGOS/Archive-Extract-" version ".tar.gz")) (sha256 (base32 "00zq2ishxk70192sjl1wciq14vhb9isz8rcafcy1j89va1srpvrn")))) (build-system perl-build-system) (home-page "https://metacpan.org/release/Archive-Extract") (synopsis "Generic archive extracting mechanism") (description "It allows you to extract any archive file of the type .tar, .tar.gz, .gz, .Z, tar.bz2, .tbz, .bz2, .zip, .xz,, .txz, .tar.xz or .lzma without having to worry how it does so, or use different interfaces for each type by using either Perl modules, or command-line tools on your system.") (license license:perl-license))) (define-public perl-archive-zip (package (name "perl-archive-zip") (version "1.68") (source (origin (method url-fetch) (uri (string-append "mirror://cpan/authors/id/P/PH/PHRED/Archive-Zip-" version ".tar.gz")) (sha256 (base32 "0l663s3a68p8r2qjy4pn1g05lx0i8js8wpz7qqln3bsvg1fihklq")))) (build-system perl-build-system) (native-inputs ;; For tests. `(("perl-test-mockmodule" ,perl-test-mockmodule))) (synopsis "Provides an interface to Zip archive files") (description "The @code{Archive::Zip} module allows a Perl program to create, manipulate, read, and write Zip archive files.") (home-page "https://metacpan.org/release/Archive-Zip") (license license:perl-license)))