;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages pcre) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages compression) #:use-module (gnu packages readline) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public pcre (package (name "pcre") (version "8.32") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/pcre/pcre/" version "/pcre-" version ".tar.bz2")) (sha256 (base32 "0m8gvrf1q0iwll4csirvvj98xygw4cy7r14i5l53ivsqs2dzn4x9")))) (build-system gnu-build-system) (inputs `(("bzip2" ,bzip2) ("readline" ,readline) ("zlib" ,zlib))) (arguments `(#:configure-flags '("--enable-utf" "--enable-pcregrep-libz" "--enable-pcregrep-libbz2" "--enable-pcretest-libreadline"))) (synopsis "Perl Compatible Regular Expressions") (description "The PCRE library is a set of functions that implement regular expression pattern matching using the same syntax and semantics as Perl 5. PCRE has its own native API, as well as a set of wrapper functions that correspond to the POSIX regular expression API.") (license license:bsd-3) (home-page "http://www.pcre.org/"))) cals.el
AgeCommit message (Expand)Author
2020-05-16gexp: Add 'let-system'....Ludovic Courtès
2020-03-22store: Add 'with-build-handler'....Ludovic Courtès
2020-03-12gexp: Add 'with-parameters'....Ludovic Courtès
2019-11-29ui: Factorize 'with-profile-lock'....Ludovic Courtès
2019-11-19pull: Acquire a lock for the target profile....Ludovic Courtès
2019-09-23git: Add 'commit-difference'....Ludovic Courtès
2019-06-05syscalls: Add 'with-file-lock' macro....Ludovic Courtès
2019-05-27publish: Add support for lzip....Ludovic Courtès
2019-03-07database: Make 'register-items' transactional....Caleb Ristvedt
2019-01-11status: Add 'with-status-verbosity'....Ludovic Courtès
2018-10-19tests: Run 'guix pack' tests using the external store....Ludovic Courtès
2018-09-27Add (guix status) and use it for pretty colored output....Ludovic Courtès
2018-06-01Add (gnu store database)....Caleb Ristvedt
2018-06-01gexp: Add 'with-extensions'....Ludovic Courtès