The following 3 patches applied to 0.13.69 in this order, combined: https://github.com/gdraheim/zziplib/commit/9411bde3e4a70a81ff3ffd256b71927b2d90dcbb.patch https://github.com/gdraheim/zziplib/commit/d2e5d5c53212e54a97ad64b793a4389193fec687.patch https://github.com/gdraheim/zziplib/commit/0e1dadb05c1473b9df2d7b8f298dab801778ef99.patch diff --git a/test/test.zip b/test/test.zip index 2c992ea..952d475 100644 Binary files a/test/test.zip and b/test/test.zip differ diff --git a/zzip/zip.c b/zzip/zip.c index 14e2e06..f97a40a 100644 --- a/zzip/zip.c +++ b/zzip/zip.c @@ -472,9 +472,15 @@ __zzip_parse_root_directory(int fd, } else { if (io->fd.seeks(fd, zz_rootseek + zz_offset, SEEK_SET) < 0) + { + free(hdr0); return ZZIP_DIR_SEEK; + } if (io->fd.read(fd, &dirent, sizeof(dirent)) < __sizeof(dirent)) + { + free(hdr0); return ZZIP_DIR_READ; + } d = &dirent; } @@ -574,11 +580,18 @@ __zzip_parse_root_directory(int fd, if (hdr_return) *hdr_return = hdr0; + else + { + /* If it is not assigned to *hdr_return, it will never be free()'d */ + free(hdr0); + } } /* else zero (sane) entries */ + else + free(hdr0); # ifndef ZZIP_ALLOW_MODULO_ENTRIES - return (entries != zz_entries ? ZZIP_CORRUPTED : 0); + return (entries != zz_entries) ? ZZIP_CORRUPTED : 0; # else - return ((entries & (unsigned)0xFFFF) != zz_entries ? ZZIP_CORRUPTED : 0); + return ((entries & (unsigned)0xFFFF) != zz_entries) ? ZZIP_CORRUPTED : 0; # endif } 55ab6649c32ef838762058ae95c5b'/>
path: root/gnu/packages/tex.scm
AgeCommit message (Expand)Author
2020-01-06Adjust module autoloads....Ludovic Courtès
2019-11-13gnu: texlive-latex-pdfx: Declare source file-name....Efraim Flashner
2019-11-13gnu: texlive-latex-xmpincl: Declare source file-name....Efraim Flashner
2019-11-13gnu: texlive-latex-changepage: Declare source file-name....Efraim Flashner
2019-11-13gnu: texlive-latex-mflogo: Declare source file-name....Efraim Flashner
2019-11-13gnu: texlive-standalone: Declare source file-name....Efraim Flashner
2019-11-13gnu: texlive-booktabs: Declare source file-name....Efraim Flashner
2019-11-13gnu: texlive-latex-xkeyval: Declare source file-name....Efraim Flashner
2019-11-12gnu: lyx: Download over HTTPS....Tobias Geerinckx-Rice
2019-11-12gnu: lyx: Use Python 3....Tobias Geerinckx-Rice
2019-11-12gnu: lyx: Update to 2.3.3....Tobias Geerinckx-Rice
2019-11-12gnu: lyx: Don't use NAME in source URI....Tobias Geerinckx-Rice