This test fails with "error.CompilationIncorrectlySucceeded".
diff --git a/test/compile_errors.zig b/test/compile_errors.zig
index fd1255c..20d5548 100644
--- a/test/compile_errors.zig
+++ b/test/compile_errors.zig
@@ -2751,15 +2751,15 @@ pub fn addCases(cases: *tests.CompileErrorContext) void {
"tmp.zig:3:5: error: dependency on libc must be explicitly specified in the build command",
});
- cases.addTest("libc headers note",
- \\const c = @cImport(@cInclude("stdio.h"));
- \\export fn entry() void {
- \\ _ = c.printf("hello, world!\n");
- \\}
- , &[_][]const u8{
- "tmp.zig:1:11: error: C import failed",
- "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
- });
+// cases.addTest("libc headers note",
+// \\const c = @cImport(@cInclude("stdio.h"));
+// \\export fn entry() void {
+// \\ _ = c.printf("hello, world!\n");
+// \\}
+// , &[_][]const u8{
+// "tmp.zig:1:11: error: C import failed",
+// "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
+// });
}
cases.addTest("comptime vector overflow shows the index",
a>commitdiff
|
Age | Commit message (Expand) | Author |
2022-01-09 | nls: Update translations....* po/doc/guix-cookbook.fi.po: New file.
* po/doc/guix-manual.fi.po: New file.
* po/doc/local.mk: Add them.
* doc/local.mk: Add them.
* po/guix/fi.po: New file.
* po/guix/LINGUAS: Add it.
| Julien Lepiller |
2021-12-04 | nls: Update translations. | Julien Lepiller |
2021-11-06 | nls: Update translations....* po/doc/guix-cookbook.es.po: New file.
* po/doc/local.mk: Add 'es' cookbook.
* doc/local.mk: Add 'es' cookbook.
| Julien Lepiller |
2021-10-17 | nls: Update translations. | Julien Lepiller |
2021-09-02 | nls: Update translations....* po/packages/it.po: New file.
* po/packages/LINGUAS: Add `it'.
* po/*/*.po: Update translations.
| Julien Lepiller |
2021-08-04 | nls: Update translations....* po/doc/guix-cookbook.ru.po: New file.
* po/doc/guix-cookbook.sk.po: New file.
* po/*/*.po: Update translations.
* doc/local.mk (COOKBOOK_LANGUAGES): Add ru and sk.
(info_TEXINFOS): Add Russian and Slovak cookbooks.
* po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add Russian and Slovak po
files.
| Julien Lepiller |
2021-05-11 | nls: Update translations. | Maxim Cournoyer |
2021-05-10 | nls: Update translations. | Maxim Cournoyer |
2021-04-18 | nls: Update 'fr' translations. | Julien Lepiller |