From: Danny Milosavljevic Date: Thu, 2 Apr 2022 12:10:00 +0200 Subject: Make xterm use libxcursor directly Fixes . This patch makes xterm use libxcursor directly. Without it, libx11 would try to dlopen("libXcursor.so.1") and fail. --- xterm-370/misc.c.orig 2022-04-02 11:52:26.225131854 +0200 +++ xterm-370/misc.c 2022-04-02 12:06:13.091482385 +0200 @@ -79,6 +79,9 @@ #ifdef HAVE_LIBXPM #include #endif +#ifdef HAVE_LIB_XCURSOR +#include +#endif #ifdef HAVE_LANGINFO_CODESET #include @@ -866,7 +869,14 @@ * 0, 2 a shape, 3 a mask for 2, etc. * contains defined names for each shape. */ - c = XCreateGlyphCursor(dpy, + c = XcursorTryShapeCursor(dpy, + myFont.fs->fid, /* source_font */ + myFont.fs->fid, /* mask_font */ + c_index + 0, /* source_char */ + c_index + 1, /* mask_char */ + &foreground, + &background); + if (c == None) c = XCreateGlyphCursor(dpy, myFont.fs->fid, /* source_font */ myFont.fs->fid, /* mask_font */ c_index + 0, /* source_char */ 3fc0894c3cce1b929e53a9c05839cab83036'>treecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-10 17:17:48 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:50:31 +0100
commit0c383fc0894c3cce1b929e53a9c05839cab83036 (patch)
tree54e64ad70c3dfd32e4593b2a8ad86a2e788b17ec /gnu
parent564a85a0ab7fc469b4fb54766881793114b5ae0d (diff)
downloadguix-0c383fc0894c3cce1b929e53a9c05839cab83036.tar.gz
guix-0c383fc0894c3cce1b929e53a9c05839cab83036.zip
gnu: Add rust-getset-0.1.
* gnu/packages/crates-io.scm (rust-getset-0.1): New variable.
Diffstat (limited to 'gnu')