Distriction specific patch, not going upstream
Disable systemd-run if the command is not found.
diff --git a/xpra/scripts/main.py b/xpra/scripts/main.py
index 1c5e8ddaad..084aabe792 100755
--- a/xpra/scripts/main.py
+++ b/xpra/scripts/main.py
@@ -396,23 +396,26 @@ def use_systemd_run(s) -> bool:
cmd = ["systemd-run", "--quiet"]
if getuid() != 0:
cmd += ["--user"]
- cmd += ["--scope", "--", "true"]
- proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
try:
- proc.communicate(timeout=2)
- r = proc.returncode
- except TimeoutExpired: # pragma: no cover
- r = None
- if r is None:
- try:
- proc.terminate()
- except Exception:
- pass
+ cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
+ proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False)
try:
- proc.communicate(timeout=1)
+ proc.communicate(timeout=2)
+ r = proc.returncode
except TimeoutExpired: # pragma: no cover
r = None
- return r == 0
+ if r is None:
+ try:
+ proc.terminate()
+ except Exception:
+ pass
+ try:
+ proc.communicate(timeout=1)
+ except TimeoutExpired: # pragma: no cover
+ r = None
+ return r==0
+ except FileNotFoundError:
+ return False
def verify_gir():
achefilesd.scm?id=0b95de9b3bad19da20cb034ca2bc245c2b48cf00'>diff
|
Age | Commit message (Expand) | Author |
2023-08-15 | services: Add cachefilesd service....Thanks to Bruno Victal "mirai" for cooperating on this patch and for
generously sharing a wealth of insights about Guix services.
Thanks to Jean-Baptiste Note for an early version of this service!
* doc/guix.texi (Linux Services)[Cachefilesd Service]: New heading.
* gnu/services/linux.scm (serialize-string, non-negative-integer?)
(serialize-non-negative-integer, string, non-negative-integer)
(make-option-serializer, make-percentage-threshold-serializer): New
procedures.
(cachefilesd-configuration): New record type.
(cachefilesd-service-type): New variable.
* gnu/tests/cachefilesd.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Co-authored-by: Bruno Victal <mirai@makinata.eu>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Felix Lechner |