Disable systemd-run if the command is not found. diff -ru xpra-4.2~/xpra/scripts/main.py xpra-4.2/xpra/scripts/main.py --- xpra-4.2~/xpra/scripts/main.py 2021-06-06 08:51:13.756815842 -0700 +++ xpra-4.2/xpra/scripts/main.py 2021-06-06 16:07:13.371024486 -0700 @@ -331,23 +331,26 @@ if not is_systemd_pid1(): return False # pragma: no cover #test it: - cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"] - proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False) try: - proc.communicate(timeout=2) - r = proc.returncode - except TimeoutExpired: # pragma: no cover - r = None - if r is None: + cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"] + proc = Popen(cmd, stdout=PIPE, stderr=PIPE, shell=False) try: - proc.terminate() - except Exception: - pass - try: - proc.communicate(timeout=1) + proc.communicate(timeout=2) + r = proc.returncode except TimeoutExpired: # pragma: no cover r = None - return r==0 + if r is None: + try: + proc.terminate() + except Exception: + pass + try: + proc.communicate(timeout=1) + except TimeoutExpired: # pragma: no cover + r = None + return r==0 + except FileNotFoundError: + return False def run_mode(script_file, error_cb, options, args, mode, defaults): d' value='a5481f7cef8e710428b334fbe9c4fbcb1ad0a873'/>
path: root/ROADMAP
3d833db0b'>nls: Update.
AgeCommit message (Expand)Author
2021-05-20The #guix channel is hosted by Libera Chat....* README (Contact): Update network name. * ROADMAP: Likewise. * doc/contributing.texi (Contributing): Likewise. * doc/guix.texi (After System Installation): Likewise. Tobias Geerinckx-Rice
Ludovic Courtès
2020-03-23nls: Update.Ludovic Courtès
2020-02-14Revert "nls: Update 'es' translation of the manual."...I believe this change breaks guix pull: ./guix.es.texi:20971: @samp missing closing brace This reverts commit d156e3fbcd6fc61a39d1d32622b90b0f8f741729. Christopher Baines
2020-02-14nls: Update 'es' translation of the manual.Julien Lepiller
2019-08-31nls: Update 'es' translation of the manual.Julien Lepiller
2019-05-13nls: Update es translation.Ludovic Courtès
2019-05-01nls: Fix cross-reference syntax error in 'guix-manual.es.po'....* po/doc/guix-manual.es.po: Replace "@pref" with "@pxref". Ludovic Courtès
2019-05-01nls: Update manual translations for de, es, fr, and zh_CN.Ludovic Courtès
2019-04-25nls: Update 'es' translation.Julien Lepiller
2019-04-23doc: Add Spanish translation....* doc/local.mk (info_TEXINFOS): Add guix.es.texi. (TRANSLATED_INFO): Add guix.es.texi and contributing.es.texi. * po/doc/guix-manual.es.po: New file. * po/doc/local.mk: Add guix-manual.es.po. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Miguel Ángel Arruga Vivas