From 05442de962d3dc624f79fc1a00eca3ffc5489ced Mon Sep 17 00:00:00 2001 From: Michal Srb Date: Wed, 24 May 2017 15:54:39 +0300 Subject: Xi: Zero target buffer in SProcXSendExtensionEvent. Make sure that the xEvent eventT is initialized with zeros, the same way as in SProcSendEvent. Some event swapping functions do not overwrite all 32 bytes of xEvent structure, for example XSecurityAuthorizationRevoked. Two cooperating clients, one swapped and the other not, can send XSecurityAuthorizationRevoked event to each other to retrieve old stack data from X server. This can be potentialy misused to go around ASLR or stack-protector. Signed-off-by: Michal Srb Reviewed-by: Peter Hutterer Signed-off-by: Peter Hutterer diff --git a/Xi/sendexev.c b/Xi/sendexev.c index 11d8202..1cf118a 100644 --- a/Xi/sendexev.c +++ b/Xi/sendexev.c @@ -78,7 +78,7 @@ SProcXSendExtensionEvent(ClientPtr client) { CARD32 *p; int i; - xEvent eventT; + xEvent eventT = { .u.u.type = 0 }; xEvent *eventP; EventSwapPtr proc; -- cgit v0.10.2 guix/log/m4'>logtreecommitdiff
path: root/m4
AgeCommit message (Expand)Author
2019-08-17build: 'GUIX_CHECK_GUILE_JSON' really checks for Guile-JSON 3.x....Ludovic Courtès
2019-07-25maint: Switch to Guile-JSON 3.x....Ludovic Courtès
2019-05-06Add (guix lzlib)....Pierre Neidhardt
2018-11-23Update Guile-SQLite3 URL everywhere....Ludovic Courtès
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2018-06-01build: Check for Guile-SQLite3....Ludovic Courtès
2018-02-26build: Require Guile >= 2.0.13....Ludovic Courtès
2018-01-06build: Detect broken 'equal?' in Guile 2.2.1....Ludovic Courtès