This patch is required for xmonad to make use of shared libraries.
Without it, xmonad will not work since we do not (by default) use
statically linked Haskell libraries.
index 46a0939..5ad4f8f 100644
--- a/src/XMonad/Core.hs
+++ b/src/XMonad/Core.hs
@@ -664,6 +664,8 @@ compile dirs method =
where
ghcArgs = [ "--make"
, "xmonad.hs"
+ , "-dynamic"
+ , "-fPIC"
, "-i" -- only look in @lib@
, "-ilib"
, "-fforce-recomp"
ss='main'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-11-25 | gnu: Add python-omemo-dr....* gnu/packages/python-crypto.scm (python-omemo-dr): New variable.
Change-Id: I06b31e62dff1a740fee832e17200f8905810860a
Signed-off-by: Luca Matei Pintilie <luca@lucamatei.com>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Morgan Smith |