This patch is required for xmonad to make use of shared libraries. Without it, xmonad will not work since we do not (by default) use statically linked Haskell libraries. index 46a0939..5ad4f8f 100644 --- a/src/XMonad/Core.hs +++ b/src/XMonad/Core.hs @@ -664,6 +664,8 @@ compile dirs method = where ghcArgs = [ "--make" , "xmonad.hs" + , "-dynamic" + , "-fPIC" , "-i" -- only look in @lib@ , "-ilib" , "-fforce-recomp" in'>index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/spice.scm
AgeCommit message (Collapse)Author
2020-04-21services: Don't use the deprecated 'make-forkexec-constructor' call.Ludovic Courtès
Passing 'make-forkexec-constructor' a string or several string arguments has been deprecated since dmd 0.1. * gnu/services/base.scm (rngd-service-type): In 'start' method, pass a list as the first argument to 'make-forkexec-constructor'. * gnu/services/desktop.scm (bluetooth-shepherd-service): Likewise. * gnu/services/spice.scm (spice-vdagent-shepherd-service): Likewise.
2020-01-26services: Fix typo in spice-vdagent-service.Damien Cassou
* gnu/services/spice.scm (spice-vdagent-service): Fix typo. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
2017-01-25services: Fix 'mkdir-p' in activation scripts.Clément Lassieur
* gnu/services/cups.scm (%cups-activation): Import (guix build utils). * gnu/services/mail.scm (opensmtpd-activation): Idem. * gnu/services/networking.scm (ntp-service-activation): Idem. * gnu/services/spice.scm (spice-vdagent-activation): Idem. * gnu/services/ssh.scm (openssh-activation): Idem. (dropbear-activation): Idem. * gnu/services/vpn.scm (%openvpn-activation): Idem. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2016-09-10system: Use 'file-append' to denote file names.Ludovic Courtès
* gnu/services/avahi.scm, gnu/services/base.scm, gnu/services/databases.scm, gnu/services/dbus.scm, gnu/services/desktop.scm, gnu/services/dict.scm, gnu/services/mail.scm, gnu/services/networking.scm, gnu/services/sddm.scm, gnu/services/spice.scm, gnu/services/ssh.scm, gnu/services/web.scm, gnu/services/xorg.scm, gnu/system.scm: Replace the #~(string-append #$pkg "/bin/foo") idiom with (file-append pkg "/bin/foo").
2016-08-05services: Add spice vdagent service.David Craven
* gnu/services/spice.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * doc/guix.texi (Various Services): New subheading.