Fix a file descriptor leak: https://github.com/xinetd-org/xinetd/issues/23 Patch copied from Debian: https://anonscm.debian.org/cgit/collab-maint/xinetd.git/tree/debian/patches/000012-fix_fd_leak Patch sent upstream at https://github.com/xinetd-org/xinetd/pull/26. diff --git a/xinetd/xgetloadavg.c b/xinetd/xgetloadavg.c index 5a26214..fe0f872 100644 --- a/xinetd/xgetloadavg.c +++ b/xinetd/xgetloadavg.c @@ -34,7 +34,7 @@ double xgetloadavg(void) if( fscanf(fd, "%lf", &ret) != 1 ) { perror("fscanf"); - return -1; + ret = -1; } fclose(fd); -- 2.7.4 method='get'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer/user.scm
+0200'>2020-05-20
AgeCommit message (Expand)Author
2019-04-28installer: User can have a "real name"....Ludovic Courtès
2019-04-25installer: Ask for the root account password....Ludovic Courtès
2019-04-25installer: Ask for user password and initialize /etc/shadow....Ludovic Courtès
gnu: gnu-efi: Update to 3.0.12....Tobias Geerinckx-Rice
2020-03-04Merge branch 'master' into core-updatesMarius Bakke
2020-02-16gnu: sbsigntools: Update to 0.9.3....Tobias Geerinckx-Rice