# This patch was imported from Debian: https://sources.debian.org/src/xgboost/1.5.1-1/debian/patches/cmake-dmlc-core.patch/ Index: xgboost/CMakeLists.txt =================================================================== --- xgboost.orig/CMakeLists.txt +++ xgboost/CMakeLists.txt @@ -164,7 +164,9 @@ endif (USE_NCCL) # dmlc-core msvc_use_static_runtime() -add_subdirectory(${xgboost_SOURCE_DIR}/dmlc-core) +add_library(dmlc SHARED IMPORTED) +find_library(DMLC_LIBRARY dmlc) +set_property(TARGET dmlc PROPERTY IMPORTED_LOCATION "${DMLC_LIBRARY}") if (MSVC) if (TARGET dmlc_unit_tests) @@ -222,7 +224,7 @@ set_target_properties(runxgboost PROPERT #-- End CLI for xgboost # Common setup for all targets -foreach(target xgboost objxgboost dmlc runxgboost) +foreach(target xgboost objxgboost runxgboost) xgboost_target_properties(${target}) xgboost_target_link_libraries(${target}) xgboost_target_defs(${target}) @@ -273,7 +275,7 @@ install(DIRECTORY ${xgboost_SOURCE_DIR}/ # # https://github.com/dmlc/xgboost/issues/6085 if (BUILD_STATIC_LIB) - set(INSTALL_TARGETS xgboost runxgboost objxgboost dmlc) + set(INSTALL_TARGETS xgboost runxgboost objxgboost) else (BUILD_STATIC_LIB) set(INSTALL_TARGETS xgboost runxgboost) endif (BUILD_STATIC_LIB) '>treecommitdiff
path: root/tests/monads.scm
AgeCommit message (Expand)Author
2016-04-03build: Add a Guile custom test driver using SRFI-64....Mathieu Lirzin
2016-03-06tests: Disable grafting by default for most tests....Ludovic Courtès
2015-09-04monads: Fix 'liftN' fallback case....Ludovic Courtès
2015-06-08monads: Allow n-ary '>>=' expressions....Ludovic Courtès
2015-05-27monads: 'foldm', 'mapm', and 'anym' now take a list of regular values....Ludovic Courtès
2015-01-17monads: Add the state monad....Ludovic Courtès
2015-01-14monads: Move '%store-monad' and related procedures where they belong....Ludovic Courtès
2015-01-12monads: Remove 'derivation-expression'....Ludovic Courtès
2015-01-12monads: Rewrite 'text-file*' using gexps....Ludovic Courtès
2014-10-08monads: Add 'mbegin'....Ludovic Courtès
2014-10-05gnu: cross-base: Use the right dynamic linker name....Ludovic Courtès
2014-08-23Factorize test suite support in (guix tests)....Ludovic Courtès
2014-08-17monads: 'package-file' uses '%current-system' at '>>=' time....Ludovic Courtès
2014-08-17monads: Add 'package->cross-derivation' and #:target for 'package-file'....Ludovic Courtès
2014-07-24monads: Add 'interned-file'....Ludovic Courtès
2014-07-12monads: Fix 'mapm' so that effects happen from left to right....Ludovic Courtès